summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/blogc-git-receiver/blogc-git-receiver-0.2.ebuild')
-rw-r--r--dev-vcs/blogc-git-receiver/blogc-git-receiver-0.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-vcs/blogc-git-receiver/blogc-git-receiver-0.2.ebuild b/dev-vcs/blogc-git-receiver/blogc-git-receiver-0.2.ebuild
new file mode 100644
index 000000000000..5b79d3045865
--- /dev/null
+++ b/dev-vcs/blogc-git-receiver/blogc-git-receiver-0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/blogc/blogc-git-receiver.git
+ https://github.com/blogc/blogc-git-receiver.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A simple login shell/git hook to deploy blogc websites"
+HOMEPAGE="https://github.com/blogc/blogc-git-receiver"
+
+MY_PV="${PV/_/-}"
+MY_PV="${MY_PV/beta/beta.}"
+
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="https://github.com/blogc/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+DEPEND=""
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}