summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/cvsps/cvsps-2.2_beta1-r1.ebuild')
-rw-r--r--dev-vcs/cvsps/cvsps-2.2_beta1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/cvsps/cvsps-2.2_beta1-r1.ebuild b/dev-vcs/cvsps/cvsps-2.2_beta1-r1.ebuild
new file mode 100644
index 000000000000..0a94dcb6c9b5
--- /dev/null
+++ b/dev-vcs/cvsps/cvsps-2.2_beta1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils toolchain-funcs
+
+MY_P="${P/_beta/b}"
+DESCRIPTION="Generates patchset information from a CVS repository"
+HOMEPAGE="http://www.catb.org/~esr/cvsps/"
+SRC_URI="http://www.cobite.com/cvsps/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1-build.patch
+ "${FILESDIR}"/${P}-solaris.patch
+)
+
+src_prepare() {
+ default
+
+ # no configure around
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e '/^LDLIBS+=/s/$/ -lsocket/' Makefile || die
+ fi
+ tc-export CC
+}
+
+src_install() {
+ dobin cvsps
+ doman cvsps.1
+ dodoc README CHANGELOG
+}