summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-annex')
-rw-r--r--dev-vcs/git-annex/Manifest3
-rw-r--r--dev-vcs/git-annex/git-annex-10.20220624.ebuild (renamed from dev-vcs/git-annex/git-annex-8.20200810.ebuild)79
-rw-r--r--dev-vcs/git-annex/git-annex-10.20230802.ebuild142
-rw-r--r--dev-vcs/git-annex/metadata.xml27
4 files changed, 181 insertions, 70 deletions
diff --git a/dev-vcs/git-annex/Manifest b/dev-vcs/git-annex/Manifest
index 7306f3571bc6..6467c7376d43 100644
--- a/dev-vcs/git-annex/Manifest
+++ b/dev-vcs/git-annex/Manifest
@@ -1 +1,2 @@
-DIST git-annex-8.20200810.tar.gz 1312890 BLAKE2B 63226ee6b2150dd48dae3e52e70502e64e89d73185500c1cea201f2be98760ed9b3cd173b75b5603b49ca63f316163273a7c6d7eaddd68e548d903c845925713 SHA512 e6a4ad3169582f65284218c75f2679105a52d2f22310b10436796c439e031c5ad6f4d2dff1772f4cfc670d8956ae4a68d4d98e1dabd48bf06bcafda97676321f
+DIST git-annex-10.20220624.tar.gz 1426982 BLAKE2B fa3a105f9677c51dfb1a44984ac80a377380ff5e2c69486f6f213fcb709c2280c66b8d856f004016f97751abea3faeca8756663c0af19616ed237d8e4d9d25f9 SHA512 4269c3408c9368283ab280c7231953ad95687b5ff84c1e9cb725d5ed6eb4da9384c48de33e4265d2fd8b1352eea47bffaac7d335d2c998149555b050f80a75af
+DIST git-annex-10.20230802.tar.gz 1481981 BLAKE2B 5c7bf5695fb62f9d1aecf4e1a65d1bee726a55396efc5ccd9881bd0086dee4b679814ccaaf9ac5bf191b46b629b6dc86f43aed4cdc32423af35ede745ddf7219 SHA512 6d8235cfcc9993c3db415b606ebb818183df313531c14be85a7ae353e1822dc22250aa25ed60153e75732e846319e5f20f714354f45029776060b4a838a26471
diff --git a/dev-vcs/git-annex/git-annex-8.20200810.ebuild b/dev-vcs/git-annex/git-annex-10.20220624.ebuild
index c80e75b51846..47a14cc79186 100644
--- a/dev-vcs/git-annex/git-annex-8.20200810.ebuild
+++ b/dev-vcs/git-annex/git-annex-10.20220624.ebuild
@@ -1,28 +1,36 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.6.9999
-#hackport: flags: -production,-android,-androidsplice,-testsuite
+# ebuild generated by hackport 0.7.1.2.9999
+#hackport: flags: -production,-android,-androidsplice,-testsuite,+networkbsd
CABAL_FEATURES=""
inherit haskell-cabal bash-completion-r1 desktop
DESCRIPTION="manage files with git, without checking their contents into git"
-HOMEPAGE="http://git-annex.branchable.com/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+HOMEPAGE="https://git-annex.branchable.com/"
LICENSE="AGPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="+assistant benchmark +dbus debuglocks doc +gitlfs +httpclientrestricted +magicmime +networkbsd +pairing +s3 +torrentparser +webapp +webdav" # NOTE: add local USE flag 'doc' when bumping
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+IUSE="+assistant +benchmark +dbus debug doc +gitlfs +magicmime +pairing +torrentparser +webapp"
-RESTRICT=test
+REQUIRED_USE="webapp? ( assistant )"
+
+GHC_BOOTSTRAP_PACKAGES=(
+ async
+ filepath-bytestring
+ split
+ unix-compat
+)
RDEPEND="dev-haskell/aeson:=
+ >=dev-haskell/ansi-terminal-0.9:=
dev-haskell/async:=
- dev-haskell/attoparsec:=
+ >=dev-haskell/attoparsec-0.13.2.2:=
+ >=dev-haskell/aws-0.20:=
>=dev-haskell/bloomfilter-2.0.0:=
dev-haskell/byteable:=
dev-haskell/case-insensitive:=
@@ -32,15 +40,15 @@ RDEPEND="dev-haskell/aeson:=
dev-haskell/crypto-api:=
>=dev-haskell/cryptonite-0.23:=
dev-haskell/data-default:=
+ >=dev-haskell/dav-1.0:=
dev-haskell/disk-free-space:=
dev-haskell/dlist:=
dev-haskell/edit-distance:=
- >=dev-haskell/exceptions-0.6:=
>=dev-haskell/feed-1.0.0:=
>=dev-haskell/filepath-bytestring-1.4.2.1.1:=
dev-haskell/free:=
- dev-haskell/hslogger:=
>=dev-haskell/http-client-0.5.3:=
+ >=dev-haskell/http-client-restricted-0.0.2:=
dev-haskell/http-client-tls:=
>=dev-haskell/http-conduit-2.3.0:=
>=dev-haskell/http-types-0.7:=
@@ -48,15 +56,16 @@ RDEPEND="dev-haskell/aeson:=
dev-haskell/memory:=
dev-haskell/microlens:=
dev-haskell/monad-control:=
- dev-haskell/monad-logger:=
- >=dev-haskell/mtl-2:=
+ >=dev-haskell/monad-logger-0.3.10:=
+ >=dev-haskell/network-3.0.0.0:=
+ dev-haskell/network-bsd:=
>=dev-haskell/network-uri-2.6:=
dev-haskell/old-locale:=
>=dev-haskell/optparse-applicative-0.14.1:=
>=dev-haskell/persistent-2.8.1:=
>=dev-haskell/persistent-sqlite-2.8.1:=
dev-haskell/persistent-template:=
- >=dev-haskell/quickcheck-2.10.0:2=
+ >=dev-haskell/quickcheck-2.10.0:=
dev-haskell/random:=
dev-haskell/regex-tdfa:=
dev-haskell/resourcet:=
@@ -68,32 +77,26 @@ RDEPEND="dev-haskell/aeson:=
>=dev-haskell/stm-2.3:=
dev-haskell/stm-chans:=
dev-haskell/tagsoup:=
- >=dev-haskell/tasty-0.7:=
+ >=dev-haskell/tasty-1.2:=
dev-haskell/tasty-hunit:=
dev-haskell/tasty-quickcheck:=
dev-haskell/tasty-rerun:=
- dev-haskell/text:=
>=dev-haskell/unix-compat-0.5:=
dev-haskell/unliftio-core:=
dev-haskell/unordered-containers:=
dev-haskell/utf8-string:=
>=dev-haskell/uuid-1.2.6:=
dev-haskell/vector:=
- >=dev-lang/ghc-8.4.3:=
+ >=dev-lang/ghc-8.10.1:=
assistant? ( >=dev-haskell/hinotify-0.3.10:=
dev-haskell/mountpoints:= )
benchmark? ( dev-haskell/criterion:= )
dbus? ( >=dev-haskell/dbus-0.10.7:=
>=dev-haskell/fdo-notify-0.3:= )
- gitlfs? ( >=dev-haskell/git-lfs-1.1.0:= )
- httpclientrestricted? ( >=dev-haskell/http-client-restricted-0.0.2:= )
+ gitlfs? ( >=dev-haskell/git-lfs-1.2.0:= )
magicmime? ( dev-haskell/magic:= )
- networkbsd? ( >=dev-haskell/network-3.0.0.0:=
- dev-haskell/network-bsd:= )
- !networkbsd? ( >=dev-haskell/network-2.6.3.0:= <dev-haskell/network-3.0.0.0:= )
pairing? ( dev-haskell/network-info:=
dev-haskell/network-multicast:= )
- s3? ( >=dev-haskell/aws-0.20:= )
torrentparser? ( >=dev-haskell/torrent-10000.0.0:= )
webapp? ( dev-haskell/blaze-builder:=
dev-haskell/clientsession:=
@@ -107,15 +110,14 @@ RDEPEND="dev-haskell/aeson:=
>=dev-haskell/yesod-core-1.6.0:=
>=dev-haskell/yesod-form-1.4.8:=
>=dev-haskell/yesod-static-1.5.1:= )
- webdav? ( >=dev-haskell/dav-1.0:= )
-"
-# not generated by hackport:
-RDEPEND+=" dev-vcs/git
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1
+ >=dev-haskell/cabal-3.2.0.0
+ >=dev-haskell/filepath-bytestring-1.4.2.1.4
"
# not generated by hackport:
+RDEPEND+=" dev-vcs/git
+"
DEPEND+=" dev-lang/perl
doc? ( www-apps/ikiwiki net-misc/rsync )
"
@@ -127,28 +129,15 @@ src_configure() {
$(cabal_flag assistant assistant) \
$(cabal_flag benchmark benchmark) \
$(cabal_flag dbus dbus) \
- $(cabal_flag debuglocks debuglocks) \
+ $(cabal_flag debug debuglocks) \
$(cabal_flag gitlfs gitlfs) \
- $(cabal_flag httpclientrestricted httpclientrestricted) \
$(cabal_flag magicmime magicmime) \
- $(cabal_flag networkbsd networkbsd) \
+ --flag=networkbsd \
$(cabal_flag pairing pairing) \
--flag=-production \
- $(cabal_flag s3 s3) \
--flag=-testsuite \
$(cabal_flag torrentparser torrentparser) \
- $(cabal_flag webapp webapp) \
- $(cabal_flag webdav webdav)
-}
-
-src_test() {
- if use webapp; then
- export GIT_CONFIG=${T}/temp-git-config
- git config user.email "git@src_test"
- git config user.name "Mr. ${P} The Test"
-
- emake test
- fi
+ $(cabal_flag webapp webapp)
}
src_install() {
diff --git a/dev-vcs/git-annex/git-annex-10.20230802.ebuild b/dev-vcs/git-annex/git-annex-10.20230802.ebuild
new file mode 100644
index 000000000000..6d160a5cd4e0
--- /dev/null
+++ b/dev-vcs/git-annex/git-annex-10.20230802.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: -production,-android,-androidsplice,-testsuite,+networkbsd
+
+CABAL_FEATURES=""
+inherit haskell-cabal bash-completion-r1 desktop
+
+DESCRIPTION="manage files with git, without checking their contents into git"
+HOMEPAGE="https://git-annex.branchable.com/"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+IUSE="+assistant +benchmark +dbus debug +gitlfs +magicmime +pairing +torrentparser"
+
+GHC_BOOTSTRAP_PACKAGES=(
+ async
+ filepath-bytestring
+ split
+ unix-compat
+)
+
+RDEPEND="dev-haskell/aeson:=
+ >=dev-haskell/ansi-terminal-0.9:=
+ dev-haskell/async:=
+ >=dev-haskell/attoparsec-0.13.2.2:=
+ >=dev-haskell/aws-0.20:=
+ >=dev-haskell/bloomfilter-2.0.0:=
+ dev-haskell/byteable:=
+ dev-haskell/case-insensitive:=
+ >=dev-haskell/concurrent-output-1.10:=
+ dev-haskell/conduit:=
+ dev-haskell/crypto-api:=
+ >=dev-haskell/cryptonite-0.23:=
+ dev-haskell/data-default:=
+ >=dev-haskell/dav-1.0:=
+ dev-haskell/disk-free-space:=
+ dev-haskell/dlist:=
+ dev-haskell/edit-distance:=
+ >=dev-haskell/feed-1.0.0:=
+ >=dev-haskell/filepath-bytestring-1.4.2.1.1:=
+ dev-haskell/free:=
+ >=dev-haskell/http-client-0.5.3:=
+ >=dev-haskell/http-client-restricted-0.0.2:=
+ dev-haskell/http-client-tls:=
+ >=dev-haskell/http-conduit-2.3.0:=
+ >=dev-haskell/http-types-0.7:=
+ dev-haskell/ifelse:=
+ dev-haskell/memory:=
+ dev-haskell/microlens:=
+ dev-haskell/monad-control:=
+ >=dev-haskell/monad-logger-0.3.10:=
+ >=dev-haskell/network-3.0.0.0:=
+ dev-haskell/network-bsd:=
+ >=dev-haskell/network-uri-2.6:=
+ dev-haskell/old-locale:=
+ >=dev-haskell/optparse-applicative-0.14.2:=
+ >=dev-haskell/persistent-2.8.1:=
+ >=dev-haskell/persistent-sqlite-2.8.1:=
+ dev-haskell/persistent-template:=
+ >=dev-haskell/quickcheck-2.10.0:=
+ dev-haskell/random:=
+ dev-haskell/regex-tdfa:=
+ dev-haskell/resourcet:=
+ dev-haskell/safesemaphore:=
+ dev-haskell/sandi:=
+ dev-haskell/securemem:=
+ dev-haskell/socks:=
+ dev-haskell/split:=
+ dev-haskell/stm-chans:=
+ dev-haskell/tagsoup:=
+ >=dev-haskell/tasty-1.2:=
+ dev-haskell/tasty-hunit:=
+ dev-haskell/tasty-quickcheck:=
+ dev-haskell/tasty-rerun:=
+ dev-haskell/text:=
+ >=dev-haskell/unix-compat-0.5:= <dev-haskell/unix-compat-0.8:=
+ dev-haskell/unliftio-core:=
+ dev-haskell/unordered-containers:=
+ dev-haskell/utf8-string:=
+ >=dev-haskell/uuid-1.2.6:=
+ dev-haskell/vector:=
+ >=dev-lang/ghc-8.10.1:=
+ assistant? ( dev-haskell/blaze-builder:=
+ dev-haskell/clientsession:=
+ >=dev-haskell/hinotify-0.3.10:=
+ dev-haskell/mountpoints:=
+ >=dev-haskell/path-pieces-0.2.1:=
+ >=dev-haskell/shakespeare-2.0.11:=
+ dev-haskell/wai:=
+ dev-haskell/wai-extra:=
+ >=dev-haskell/warp-3.2.8:=
+ >=dev-haskell/warp-tls-3.2.2:=
+ >=dev-haskell/yesod-1.4.3:=
+ >=dev-haskell/yesod-core-1.6.0:=
+ >=dev-haskell/yesod-form-1.4.8:=
+ >=dev-haskell/yesod-static-1.5.1:= )
+ benchmark? ( dev-haskell/criterion:= )
+ dbus? ( >=dev-haskell/dbus-0.10.7:=
+ >=dev-haskell/fdo-notify-0.3:= )
+ gitlfs? ( >=dev-haskell/git-lfs-1.2.0:= )
+ magicmime? ( dev-haskell/magic:= )
+ pairing? ( dev-haskell/network-info:=
+ dev-haskell/network-multicast:= )
+ torrentparser? ( >=dev-haskell/torrent-10000.0.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0 <dev-haskell/cabal-4.0
+ >=dev-haskell/filepath-bytestring-1.4.2.1.4
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-android \
+ --flag=-androidsplice \
+ $(cabal_flag assistant assistant) \
+ $(cabal_flag benchmark benchmark) \
+ $(cabal_flag dbus dbus) \
+ $(cabal_flag debug debuglocks) \
+ $(cabal_flag gitlfs gitlfs) \
+ $(cabal_flag magicmime magicmime) \
+ --flag=networkbsd \
+ $(cabal_flag pairing pairing) \
+ --flag=-production \
+ --flag=-testsuite \
+ $(cabal_flag torrentparser torrentparser)
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ newbashcomp "${FILESDIR}"/${PN}.bash ${PN}
+
+ dodoc CHANGELOG README
+
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry "${PN} webapp" "git-annex" ${PN}.xpm "Office"
+}
diff --git a/dev-vcs/git-annex/metadata.xml b/dev-vcs/git-annex/metadata.xml
index 0f121b9748a2..150d88b169fe 100644
--- a/dev-vcs/git-annex/metadata.xml
+++ b/dev-vcs/git-annex/metadata.xml
@@ -9,34 +9,13 @@
<flag name="assistant">Enable git-annex assistant and watch command</flag>
<flag name="benchmark">Enable benchmarking</flag>
<flag name="dbus">Enable dbus support</flag>
- <flag name="debuglocks">Debug location of MVar/STM deadlocks</flag>
<flag name="gitlfs">Build with git-lfs library (rather than vendored copy)</flag>
- <flag name="httpclientrestricted">Build with http-client-restricted library (rather than vendored copy)</flag>
<flag name="magicmime">Use libmagic to determine file MIME types</flag>
- <flag name="networkbsd">Build with network-3.0 which split out network-bsd</flag>
<flag name="pairing">Enable pairing</flag>
- <flag name="s3">Enable S3 support</flag>
<flag name="torrentparser">Use haskell torrent library to parse torrent files</flag>
<flag name="webapp">Enable git-annex webapp</flag>
- <flag name="webdav">Enable WebDAV support</flag>
</use>
- <longdescription>
- git-annex allows managing files with git, without checking the file
- contents into git. While that may seem paradoxical, it is useful when
- dealing with files larger than git can currently easily handle, whether due
- to limitations in memory, time, or disk space.
-
- It can store large files in many places, from local hard drives, to a
- large number of cloud storage services, including S3, WebDAV,
- and rsync, with a dozen cloud storage providers usable via plugins.
- Files can be stored encrypted with gpg, so that the cloud storage
- provider cannot see your data. git-annex keeps track of where each file
- is stored, so it knows how many copies are available, and has many
- facilities to ensure your data is preserved.
-
- git-annex can also be used to keep a folder in sync between computers,
- noticing when files are changed, and automatically committing them
- to git and transferring them to other computers. The git-annex webapp
- makes it easy to set up and use git-annex this way.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">git-annex</remote-id>
+ </upstream>
</pkgmetadata>