summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-cola/git-cola-3.5-r1.ebuild')
-rw-r--r--dev-vcs/git-cola/git-cola-3.5-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-vcs/git-cola/git-cola-3.5-r1.ebuild b/dev-vcs/git-cola/git-cola-3.5-r1.ebuild
index 0c0122bcd5b6..e6a1500ea821 100644
--- a/dev-vcs/git-cola/git-cola-3.5-r1.ebuild
+++ b/dev-vcs/git-cola/git-cola-3.5-r1.ebuild
@@ -3,8 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,8} )
DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1 readme.gentoo-r1 virtualx xdg-utils
DESCRIPTION="The highly caffeinated git GUI"
@@ -37,6 +38,8 @@ BDEPEND="sys-devel/gettext
)
")"
+PATCHES=( "${FILESDIR}/${P}-py3.8-line-buffering.patch" )
+
python_prepare_all() {
# make sure that tests also use the system provided QtPy
rm -r qtpy || die
@@ -95,6 +98,9 @@ python_install_all() {
python_fix_shebang "${ED}/usr/share/git-cola/bin/git-xbase" "${ED}"/usr/bin/git-cola
python_optimize "${ED}/usr/share/git-cola/lib/cola"
+ # fix appdata installation
+ mv "${D}"/usr/share/appdata "${D}"/usr/share/metainfo || die "moving appdata failed"
+
use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
distutils-r1_python_install_all