summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-mailz/git-mailz-0.14.ebuild')
-rw-r--r--dev-vcs/git-mailz/git-mailz-0.14.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-vcs/git-mailz/git-mailz-0.14.ebuild b/dev-vcs/git-mailz/git-mailz-0.14.ebuild
index aee97820b015..99ee973ab4e0 100644
--- a/dev-vcs/git-mailz/git-mailz-0.14.ebuild
+++ b/dev-vcs/git-mailz/git-mailz-0.14.ebuild
@@ -1,28 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils
+EAPI=7
DESCRIPTION="Send a collection of patches as emails"
HOMEPAGE="https://github.com/roman-neuhauser/git-mailz/"
-
SRC_URI="http://codex.sigpipe.cz/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-
KEYWORDS="~amd64 ~x86"
-DEPEND=""
-
RDEPEND="
- virtual/mta
- dev-vcs/git
app-shells/zsh
+ dev-vcs/git
+ virtual/mta
"
+src_compile() {
+ emake GZIPCMD="true"
+}
+
src_install() {
emake PREFIX="${ED}/usr" install
+
+ mv "${ED}"/usr/share/man/man1/git-mailz.1{.gz,} || die
}