summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git/git-9999-r3.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index a9feb918ee25..b9b4d5a65c7f 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -38,7 +38,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv libressl mediawiki +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -103,6 +103,7 @@ REQUIRED_USE="
cgi? ( perl )
cvs? ( perl )
mediawiki? ( perl )
+ mediawiki-experimental? ( mediawiki )
subversion? ( perl )
webdav? ( curl )
gtk? ( python )
@@ -231,6 +232,13 @@ src_prepare() {
# hack, needs better upstream solution
epatch "${FILESDIR}"/git-1.8.5-mw-vendor.patch
+ # add experimental patches to improve mediawiki support
+ # see patches for origin
+ if use mediawiki-experimental ; then
+ epatch "${FILESDIR}"/git-2.7.0-mediawiki-namespaces.patch
+ epatch "${FILESDIR}"/git-2.7.0-mediawiki-subpages.patch
+ fi
+
epatch "${FILESDIR}"/git-2.2.0-svn-fe-linking.patch
epatch_user
@@ -633,6 +641,7 @@ pkg_postinst() {
showpkgdeps git-instaweb \
"|| ( www-servers/lighttpd www-servers/apache www-servers/nginx )"
echo
+ use mediawiki-experimental && ewarn "Using experimental git-mediawiki patches. The stability of cloned wiki filesystems is not guaranteed."
}
pkg_postrm() {