summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/gitstats')
-rw-r--r--dev-vcs/gitstats/files/gitstats-0_pre20151223-grep-force-text.patch11
-rw-r--r--dev-vcs/gitstats/gitstats-0_pre20151223.ebuild1
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-vcs/gitstats/files/gitstats-0_pre20151223-grep-force-text.patch b/dev-vcs/gitstats/files/gitstats-0_pre20151223-grep-force-text.patch
new file mode 100644
index 000000000000..9663afcd4f62
--- /dev/null
+++ b/dev-vcs/gitstats/files/gitstats-0_pre20151223-grep-force-text.patch
@@ -0,0 +1,11 @@
+--- a/gitstats 2016-04-01 09:46:31.000000000 -0300
++++ b/gitstats 2016-04-01 09:46:18.458667610 -0300
+@@ -327,7 +327,7 @@
+
+ # Collect revision statistics
+ # Outputs "<stamp> <date> <time> <timezone> <author> '<' <mail> '>'"
+- lines = getpipeoutput(['git rev-list --pretty=format:"%%at %%ai %%aN <%%aE>" %s' % getlogrange('HEAD'), 'grep -v ^commit']).split('\n')
++ lines = getpipeoutput(['git rev-list --pretty=format:"%%at %%ai %%aN <%%aE>" %s' % getlogrange('HEAD'), 'grep -av ^commit']).split('\n')
+ for line in lines:
+ parts = line.split(' ', 4)
+ author = ''
diff --git a/dev-vcs/gitstats/gitstats-0_pre20151223.ebuild b/dev-vcs/gitstats/gitstats-0_pre20151223.ebuild
index a4a6a19bd9e4..451a1522a64c 100644
--- a/dev-vcs/gitstats/gitstats-0_pre20151223.ebuild
+++ b/dev-vcs/gitstats/gitstats-0_pre20151223.ebuild
@@ -39,6 +39,7 @@ src_prepare() {
sed \
-e "s:basedirs = \[binarypath, secondarypath, '/usr/share/gitstats'\]:basedirs = \['${EPREFIX}/usr/share/gitstats'\]:g" \
-i gitstats || die "failed to fix static files path"
+ eapply "${FILESDIR}"/${P}-grep-force-text.patch
default
}