summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hg-evolve/hg-evolve-10.0.2-r1.ebuild')
-rw-r--r--dev-vcs/hg-evolve/hg-evolve-10.0.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/hg-evolve/hg-evolve-10.0.2-r1.ebuild b/dev-vcs/hg-evolve/hg-evolve-10.0.2-r1.ebuild
new file mode 100644
index 000000000000..86f87960d3a9
--- /dev/null
+++ b/dev-vcs/hg-evolve/hg-evolve-10.0.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="enables the changeset evolution feature of Mercurial"
+HOMEPAGE="https://www.mercurial-scm.org/doc/evolution/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-vcs/mercurial-4.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_prepare_all() {
+ rm hgext3rd/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r html/
+ fi
+}