summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/notify-webhook')
-rw-r--r--dev-vcs/notify-webhook/Manifest4
-rw-r--r--dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild (renamed from dev-vcs/notify-webhook/notify-webhook-20140805.ebuild)10
-rw-r--r--dev-vcs/notify-webhook/notify-webhook-20150308.ebuild57
3 files changed, 7 insertions, 64 deletions
diff --git a/dev-vcs/notify-webhook/Manifest b/dev-vcs/notify-webhook/Manifest
index f02465c442bc..77247c8030c9 100644
--- a/dev-vcs/notify-webhook/Manifest
+++ b/dev-vcs/notify-webhook/Manifest
@@ -1,3 +1 @@
-DIST notify-webhook-20140805.tar.gz 15078 SHA256 479d71c7ab9ba772a0b621638e80a14cbe6f34e8fbe851d8db93b118d4567e3f SHA512 8e10994ad26d6de86e7930a2299a8701bed0f04299f2ca14b070f00543368015628b89fd4cbf351f3e42e85cf98e7465dd94517243d1beb71b645d91a637e6d2 WHIRLPOOL 533e2118941edc2f9db4412477a76332fe27475ebc882eb8f567d39a846bf04c95cc693230ae32bc1c10bf24301117b7d6e04c08e45e0fe7cf181fe454504a4b
-DIST notify-webhook-20150308-1ff3985...BCLibCoop:ee038b5.patch 8581 SHA256 c6167fd81e88fcb8de6c37bb2c5259f1c09e6e3a7f0b61d6b58f5f5e478e585c SHA512 c72b03cbea34884c089968e67b61e654a9d365e6b2a338363b6405ab1950aaa5a1c4f8ece73181003571a88f1983458c2e9194d6b26aa103c95c1ceed8e0dd4c WHIRLPOOL 3f4be9d58f5d1a4dff2a7978d067afb0e8fb739b6836709964dec17cc386890eb1d97b0652323acaefc7ca5bc5ae25c46f1f222323d471529e92a5640541bcae
-DIST notify-webhook-20150308.tar.gz 16347 SHA256 cb9d2687eea5ab4f32f6fbc9bdb05a24c8b7755193b312a574172f6aaaca857e SHA512 7a82418d16e6cfd58b9bccaf1700c5a9258601a45a823f1b8307ee3b3c6e90ad52424421836468e34b400b07100a291fd514450a2e1b3c2d1c8dff99ee409557 WHIRLPOOL 523578237483d74d2bd4fa9f4f87277b9103c67c415fbb383629211ea91403fc11debfed70fa94069e9bd8e87a1c9e799929aa1c376244e1a2dde656609a10d8
+DIST notify-webhook-0.1.0.tar.gz 17525 SHA256 3782f588e75872e7dd25656279bab154102c476dd3b1fa24fb3af66475960d55 SHA512 1694f32b1263baecac473ffa49e6e7f9cbfdb73d1abaa88e228771e28a5ed915d9f5f21ab26b05934bdcd8694b4c4f1506763dd2f0c89c35ffa51e1d1b7d03b4 WHIRLPOOL 908e3b7e61ac8893c064d95566ee504bea1689f227ca900c27e3189e4e5be0fbe1409b24c3002feb1ee05aa85364cd2fcb620f0c4a7cdcbb1ce3c53d81bf412f
diff --git a/dev-vcs/notify-webhook/notify-webhook-20140805.ebuild b/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild
index a909d4780d58..8441e7fad76e 100644
--- a/dev-vcs/notify-webhook/notify-webhook-20140805.ebuild
+++ b/dev-vcs/notify-webhook/notify-webhook-0.1.0.ebuild
@@ -4,10 +4,12 @@
EAPI=5
+PYTHON_COMPAT=( python3_{3,4,5} pypy3 )
+
DESCRIPTION="Git post-receive web hook notifier in Python."
HOMEPAGE="https://github.com/metajack/notify-webhook"
-COMMIT='c571160f155122446e97bb01c1150b4d14ea69d6'
-SRC_URI="https://github.com/metajack/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+#COMMIT='c571160f155122446e97bb01c1150b4d14ea69d6'
+SRC_URI="https://github.com/metajack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -17,8 +19,8 @@ IUSE=""
DEPEND="dev-python/simplejson"
RDEPEND="${DEPEND}"
-MY_P="${PN}-${COMMIT}"
-S="${WORKDIR}/${MY_P}"
+#MY_P="${PN}-${COMMIT}"
+#S="${WORKDIR}/${MY_P}"
src_install() {
dodoc *markdown
diff --git a/dev-vcs/notify-webhook/notify-webhook-20150308.ebuild b/dev-vcs/notify-webhook/notify-webhook-20150308.ebuild
deleted file mode 100644
index 9262564d7192..000000000000
--- a/dev-vcs/notify-webhook/notify-webhook-20150308.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils
-
-DESCRIPTION="Git post-receive web hook notifier in Python."
-HOMEPAGE="https://github.com/metajack/notify-webhook"
-COMMIT='1ff39853e59bb0ee37c4783da8dcf3ea14cef53f'
-PATCH_COMMIT='BCLibCoop:ee038b53a48e70d9e69c86386c39b7f24736d07e'
-PATCH_DELTA="${COMMIT:0:7}...${PATCH_COMMIT:0:17}"
-PATCH_NAME="${P}-${PATCH_DELTA}.patch"
-SRC_URI="https://github.com/metajack/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz
- https://github.com/metajack/notify-webhook/compare/${PATCH_DELTA}.patch -> ${PATCH_NAME}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-python/simplejson"
-DEPEND="${RDEPEND}
- dev-util/patchutils"
-
-MY_P="${PN}-${COMMIT}"
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${P}.tar.gz
-}
-
-# Yes, this is some creative patch mangling, to avoid a manually created
-# distfile. epatch's dryrun fails on a sequence of changes that depend on each
-# other, so we can clean up the patch to actually pass that check.
-src_prepare() {
- cd "${T}"
- cp "${DISTDIR}/${PATCH_NAME}" diff
- p="newdiff"
- >$p # Make an empty file to work in
- splitdiff -a -p 1 diff # split out the patches
- # combine them to a single patch
- for f in diff.part*.patch ; do
- combinediff -p 1 $p $f >$p.new && mv $p.new $p
- done
-
- # Now apply it, and dry-run will pass too!
- cd "${S}"
- EPATCH_OPTS="-p1" epatch "${T}"/newdiff
-}
-
-src_install() {
- dodoc *markdown
- exeinto /usr/libexec/githook/$PN/
- doexe notify-webhook.py
-}