summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/rabbitvcs')
-rw-r--r--dev-vcs/rabbitvcs/Manifest1
-rw-r--r--dev-vcs/rabbitvcs/metadata.xml24
-rw-r--r--dev-vcs/rabbitvcs/rabbitvcs-0.16-r1.ebuild101
3 files changed, 0 insertions, 126 deletions
diff --git a/dev-vcs/rabbitvcs/Manifest b/dev-vcs/rabbitvcs/Manifest
deleted file mode 100644
index 08681421d9dd..000000000000
--- a/dev-vcs/rabbitvcs/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST rabbitvcs-0.16.tar.gz 1670167 BLAKE2B 44d60de0bf6beb659fe8c8d1dffdb35d1a767e47a6c9aa26515e70e46d888f4394512d2b407f9f0b28edc501392ea873dfbf44dd858169ef1943cf1e02f0eaf1 SHA512 dac3b98acb5b7ef1147105aa0f735bb964c098f764c62d0e2e601a2ce34b315a5c83b3bac8929cbac898f674c86266a200f28042aad0340c1c5273bec4a6279c
diff --git a/dev-vcs/rabbitvcs/metadata.xml b/dev-vcs/rabbitvcs/metadata.xml
deleted file mode 100644
index a2d833d6ca7d..000000000000
--- a/dev-vcs/rabbitvcs/metadata.xml
+++ /dev/null
@@ -1,24 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>xmw@gentoo.org</email>
- <name>Michael Weber</name>
- </maintainer>
- <longdescription>
- RabbitVCS is a set of graphical tools written to provide
- simple and straightforward access to the version control systems you use.
- RabbitVCS is inspired by TortoiseSVN and others.
- </longdescription>
- <use>
- <flag name="caja">Enable extension for <pkg>mate-base/caja</pkg></flag>
- <flag name="cli">Eanble console based frontend</flag>
- <flag name="diff">Use for diff command <pkg>dev-util/meld</pkg></flag>
- <flag name="gedit">Enable plugin for <pkg>app-editors/gedit</pkg></flag>
- <flag name="nautilus">Enable extension for <pkg>gnome-base/nautilus</pkg></flag>
- <flag name="thunar">Enable extension for <pkg>xfce-base/thunar</pkg></flag>
- </use>
- <upstream>
- <remote-id type="github">rabbitvcs/rabbitvcs</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-vcs/rabbitvcs/rabbitvcs-0.16-r1.ebuild b/dev-vcs/rabbitvcs/rabbitvcs-0.16-r1.ebuild
deleted file mode 100644
index f9e95ffff779..000000000000
--- a/dev-vcs/rabbitvcs/rabbitvcs-0.16-r1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit gnome2-utils distutils-r1 vcs-snapshot
-
-DESCRIPTION="Integrated version control support for your desktop"
-HOMEPAGE="http://rabbitvcs.org"
-SRC_URI="https://github.com/rabbitvcs/${PN}/tarball/v${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="caja cli diff gedit git nautilus spell thunar"
-
-RDEPEND="dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygtk[${PYTHON_USEDEP}]
- dev-python/pysvn[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- caja? ( dev-python/python-caja[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/gnome-vfs-python[${PYTHON_USEDEP}] )
- diff? ( dev-util/meld )
- gedit? ( app-editors/gedit[${PYTHON_USEDEP}] )
- git? ( dev-python/dulwich[${PYTHON_USEDEP}] )
- nautilus? ( >=dev-python/nautilus-python-0.7.0[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/gnome-vfs-python[${PYTHON_USEDEP}] )
- spell? ( dev-python/gtkspell-python[${PYTHON_USEDEP}] )
- thunar? ( dev-python/thunarx-python[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-# python_convert_shebangs -r 2 .
-
-# distutils_src_prepare
-
- # we should not do gtk-update-icon-cache from setup script
- # we prefer portage for that
- sed -e 's/"install"/"fakeinstall"/' -i "${S}/setup.py" || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install
-
- if use caja ; then
- python_moduleinto /usr/share/caja-python/extensions
- python_domodule clients/caja/RabbitVCS.py
- fi
- if use cli ; then
- python_doscript clients/cli/rabbitvcs
- fi
- if use gedit ; then
- python_moduleinto /usr/$(get_libdir)/gedit-2/plugins
- python_domodule clients/gedit/rabbitvcs-plugin.py
- insinto /usr/$(get_libdir)/gedit-2/plugins
- doins clients/gedit/rabbitvcs-gedit2.gedit-plugin
- python_moduleinto /usr/$(get_libdir)/gedit-2/plugins
- python_domodule clients/gedit/rabbitvcs-plugin.py
- insinto /usr/$(get_libdir)/gedit/plugins
- doins clients/gedit/rabbitvcs-gedit3.plugin
- fi
- if use nautilus ; then
- python_moduleinto /usr/$(get_libdir)/nautilus/extensions-2.0/python
- python_domodule clients/nautilus/RabbitVCS.py
- python_moduleinto /usr/share/nautilus-python/extensions
- python_domodule clients/nautilus-3.0/RabbitVCS.py
- fi
- if use thunar ; then
- python_moduleinto "/usr/$(get_libdir)/thunarx-2/python"
- python_domodule clients/thunar/RabbitVCS.py
- python_moduleinto "/usr/$(get_libdir)/thunarx-1/python"
- python_domodule clients/thunar/RabbitVCS.py
- fi
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-
- elog "You should restart file manager to changes take effect:"
- use caja && elog "\$ caja -q"
- use nautilus && elog "\$ nautilus -q"
- use thunar && elog "\$ thunar -q && thunar &"
- elog ""
- elog "Also you should really look at known issues page:"
- elog "http://wiki.rabbitvcs.org/wiki/support/known-issues"
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}