summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/rapidsvn')
-rw-r--r--dev-vcs/rapidsvn/files/rapidsvn-0.12.1-subversion1.9-private-api.patch129
-rw-r--r--dev-vcs/rapidsvn/files/rapidsvn-0.12.1-svncpp_link.patch4
-rw-r--r--dev-vcs/rapidsvn/rapidsvn-0.12.1-r3.ebuild118
3 files changed, 249 insertions, 2 deletions
diff --git a/dev-vcs/rapidsvn/files/rapidsvn-0.12.1-subversion1.9-private-api.patch b/dev-vcs/rapidsvn/files/rapidsvn-0.12.1-subversion1.9-private-api.patch
new file mode 100644
index 000000000000..7c84c8d481fd
--- /dev/null
+++ b/dev-vcs/rapidsvn/files/rapidsvn-0.12.1-subversion1.9-private-api.patch
@@ -0,0 +1,129 @@
+Fix compile errors due to hiding of private API in subversion 1.9.
+See also:
+ https://bugs.gentoo.org/show_bug.cgi?id=558572
+ https://slackbuilds.org/cgit/slackbuilds/commit/?id=c2df77021b476ca9484772361003df04fa03038a
+ https://github.com/RapidSVN/RapidSVN/issues/6
+
+--- rapidsvn-0.12.1/src/svncpp/client_ls.cpp
++++ rapidsvn-0.12.1/src/svncpp/client_ls.cpp
+@@ -29,6 +29,7 @@
+ #include "svn_client.h"
+ #include "svn_path.h"
+ #include "svn_sorts.h"
++#include "svn_version.h"
+ //#include "svn_utf.h"
+
+ // svncpp
+@@ -37,6 +38,8 @@
+ #include "svncpp/exception.hpp"
+
+
++#if SVN_VER_MAJOR == 1 && SVN_VER_MINOR < 8
++
+ static int
+ compare_items_as_paths(const svn_sort__item_t *a, const svn_sort__item_t *b)
+ {
+@@ -90,6 +93,72 @@
+ }
+ }
+
++#else
++
++#include <algorithm>
++
++static svn_error_t* store_entry(
++ void *baton,
++ const char *path,
++ const svn_dirent_t *dirent,
++ const svn_lock_t *,
++ const char *abs_path,
++ const char *,
++ const char *,
++ apr_pool_t *scratch_pool)
++{
++ svn::DirEntries *entries = reinterpret_cast<svn::DirEntries*>(baton);
++ if (path[0] == '\0') {
++ if (dirent->kind == svn_node_file) {
++ // for compatibility with svn_client_ls behaviour, listing a file
++ // stores that file name
++ entries->push_back(svn::DirEntry(svn_path_basename(abs_path, scratch_pool), dirent));
++ }
++ } else {
++ entries->push_back(svn::DirEntry(path, dirent));
++ }
++ return SVN_NO_ERROR;
++}
++
++static bool sort_by_path(svn::DirEntry const& a, svn::DirEntry const& b)
++{
++ return svn_path_compare_paths(a.name(), b.name()) < 0;
++}
++
++namespace svn
++{
++ DirEntries
++ Client::list(const char * pathOrUrl,
++ svn_opt_revision_t * revision,
++ bool recurse) throw(ClientException)
++ {
++ Pool pool;
++ DirEntries entries;
++
++ svn_error_t * error =
++ svn_client_list3(pathOrUrl,
++ revision,
++ revision,
++ SVN_DEPTH_INFINITY_OR_IMMEDIATES(recurse),
++ SVN_DIRENT_ALL,
++ FALSE, // fetch locks
++ FALSE, // include externals
++ &store_entry,
++ &entries,
++ *m_context,
++ pool);
++
++ if (error != SVN_NO_ERROR)
++ throw ClientException(error);
++
++ std::sort(entries.begin(), entries.end(), &sort_by_path);
++
++ return entries;
++ }
++}
++
++#endif
++
+ /* -----------------------------------------------------------------
+ * local variables:
+ * eval: (load-file "../../rapidsvn-dev.el")
+--- rapidsvn-0.12.1/include/svncpp/dirent.hpp
++++ rapidsvn-0.12.1/include/svncpp/dirent.hpp
+@@ -41,7 +41,7 @@
+ /**
+ * constructor for existing @a svn_dirent_t entries
+ */
+- DirEntry(const char * name, svn_dirent_t * dirEntry);
++ DirEntry(const char * name, const svn_dirent_t * dirEntry);
+
+ /**
+ * copy constructor
+--- rapidsvn-0.12.1/src/svncpp/dirent.cpp
++++ rapidsvn-0.12.1/src/svncpp/dirent.cpp
+@@ -47,7 +47,7 @@
+ {
+ }
+
+- Data(const char * _name, svn_dirent_t * dirEntry)
++ Data(const char * _name, const svn_dirent_t * dirEntry)
+ : name(_name), kind(dirEntry->kind), size(dirEntry->size),
+ hasProps(dirEntry->has_props != 0),
+ createdRev(dirEntry->created_rev), time(dirEntry->time)
+@@ -78,7 +78,7 @@
+ {
+ }
+
+- DirEntry::DirEntry(const char * name, svn_dirent_t * DirEntry)
++ DirEntry::DirEntry(const char * name, const svn_dirent_t * DirEntry)
+ : m(new Data(name, DirEntry))
+ {
+ }
diff --git a/dev-vcs/rapidsvn/files/rapidsvn-0.12.1-svncpp_link.patch b/dev-vcs/rapidsvn/files/rapidsvn-0.12.1-svncpp_link.patch
index 4df855fb79b4..e26ecda15d9b 100644
--- a/dev-vcs/rapidsvn/files/rapidsvn-0.12.1-svncpp_link.patch
+++ b/dev-vcs/rapidsvn/files/rapidsvn-0.12.1-svncpp_link.patch
@@ -1,7 +1,7 @@
Index: src/svncpp/Makefile.am
===================================================================
---- src/svncpp/Makefile.am (revision 7100)
-+++ src/svncpp/Makefile.am (working copy)
+--- rapidsvn-0.12.1/src/svncpp/Makefile.am (revision 7100)
++++ rapidsvn-0.12.1/src/svncpp/Makefile.am (working copy)
@@ -27,3 +27,7 @@
url.cpp \
wc.cpp
diff --git a/dev-vcs/rapidsvn/rapidsvn-0.12.1-r3.ebuild b/dev-vcs/rapidsvn/rapidsvn-0.12.1-r3.ebuild
new file mode 100644
index 000000000000..ccaeca2f2fbb
--- /dev/null
+++ b/dev-vcs/rapidsvn/rapidsvn-0.12.1-r3.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+WX_GTK_VER=3.0
+
+inherit autotools eutils fdo-mime flag-o-matic python-single-r1 versionator wxwidgets
+
+MY_PV=$(get_version_component_range 1-2)
+MY_REL="1"
+
+DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system"
+HOMEPAGE="http://rapidsvn.tigris.org/"
+SRC_URI="
+ http://www.rapidsvn.org/download/release/${PV}/${P}.tar.gz
+ doc? ( https://dev.gentoo.org/~jlec/distfiles/svncpp.dox.xz )"
+
+LICENSE="GPL-2 LGPL-2.1 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEP="
+ ${PYTHON_DEPS}
+ dev-libs/apr
+ dev-libs/apr-util
+ dev-vcs/subversion
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${COMMON_DEP}
+ doc? (
+ dev-libs/libxslt
+ app-text/docbook-sgml-utils
+ app-doc/doxygen
+ app-text/docbook-xsl-stylesheets
+ media-gfx/graphviz
+ )"
+RDEPEND="${COMMON_DEP}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-svncpp_link.patch"
+ "${FILESDIR}/${P}-locale.patch"
+ "${FILESDIR}/${P}-wx3.0.patch"
+ "${FILESDIR}/${P}-subversion1.9-private-api.patch"
+)
+
+DOCS=( HACKING.txt TRANSLATIONS )
+
+src_prepare() {
+ need-wxwidgets unicode
+ if use doc; then
+ mv "${WORKDIR}"/svncpp.dox doc/svncpp/ || die
+ fi
+ strip-linguas $(grep ^RAPIDSVN_LANGUAGES src/locale/Makefile.am | sed 's:RAPIDSVN_LANGUAGES=::g')
+ sed \
+ -e "/^RAPIDSVN_LANGUAGES/s:=.*:=${LINGUAS}:g" \
+ -i src/locale/Makefile.am || die
+
+ mv configure.in configure.ac || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags $( apr-1-config --cppflags )
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with doc manpage) \
+ $(use_with doc xsltproc) \
+ $(use_with doc doxygen) \
+ $(use_with doc dot) \
+ --with-wx-config="${WX_CONFIG}" \
+ --with-svn-lib="${EPREFIX}/usr/$(get_libdir)" \
+ --with-svn-include="${EPREFIX}/usr/include" \
+ --with-apr-config="${EPREFIX}/usr/bin/apr-1-config" \
+ --with-apu-config="${EPREFIX}/usr/bin/apu-1-config"
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc/manpage manpage
+}
+
+src_install() {
+ default
+
+ doicon src/res/rapidsvn.ico src/res/bitmaps/${PN}*.png
+ make_desktop_entry rapidsvn "RapidSVN ${PV}" \
+ "${EPREFIX}/usr/share/pixmaps/rapidsvn_32x32.png" \
+ "RevisionControl;Development"
+
+ if use doc ; then
+ doman doc/manpage/${PN}.1
+ dodoc doc/svncpp/html/*
+ fi
+
+ prune_libtool_files
+}
+
+src_test() {
+ pushd src/tests/svncpp > /dev/null || die
+ default
+ ./svncpptest | grep OK || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}