summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/repo/repo-2.30.ebuild')
-rw-r--r--dev-vcs/repo/repo-2.30.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-vcs/repo/repo-2.30.ebuild b/dev-vcs/repo/repo-2.30.ebuild
deleted file mode 100644
index 25394f1e60c7..000000000000
--- a/dev-vcs/repo/repo-2.30.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
-# of the repo project. The launcher only gets a new update when changes are
-# made in it.
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit bash-completion-r1 python-r1
-
-DESCRIPTION="Google tool for managing git, particularly multiple repos"
-HOMEPAGE="https://gerrit.googlesource.com/git-repo"
-SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}
- https://github.com/GerritCodeReview/git-repo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- !app-admin/radmind
- !dev-util/repo"
-
-S="${WORKDIR}/git-${P}"
-
-src_install() {
- python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
- newbashcomp completion.bash ${PN}
- doman man/*.[0-9]
-}