summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/stagit/stagit-1.2.ebuild')
-rw-r--r--dev-vcs/stagit/stagit-1.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-vcs/stagit/stagit-1.2.ebuild b/dev-vcs/stagit/stagit-1.2.ebuild
new file mode 100644
index 000000000000..c820b61e2951
--- /dev/null
+++ b/dev-vcs/stagit/stagit-1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Generates static HTML pages for a Git repository"
+HOMEPAGE="https://codemadness.org/stagit.html"
+SRC_URI="https://codemadness.org/releases/stagit/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/libgit2:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1-pkg-config.patch )
+
+src_install() {
+ emake DESTDIR="${D}" \
+ DOCPREFIX="${EPREFIX}"/usr/share/doc/${PF} \
+ MANPREFIX="${EPREFIX}"/usr/share/man \
+ PREFIX="${EPREFIX}"/usr \
+ install
+}