summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/stgit/stgit-2.3.2.ebuild')
-rw-r--r--dev-vcs/stgit/stgit-2.3.2.ebuild226
1 files changed, 226 insertions, 0 deletions
diff --git a/dev-vcs/stgit/stgit-2.3.2.ebuild b/dev-vcs/stgit/stgit-2.3.2.ebuild
new file mode 100644
index 000000000000..48f17d58869c
--- /dev/null
+++ b/dev-vcs/stgit/stgit-2.3.2.ebuild
@@ -0,0 +1,226 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Autogenerated by pycargoebuild 0.6.3
+
+EAPI=8
+
+CRATES="
+ adler-1.0.2
+ ahash-0.8.3
+ anstream-0.3.2
+ anstyle-1.0.1
+ anstyle-parse-0.2.1
+ anstyle-query-1.0.0
+ anstyle-wincon-1.0.2
+ anyhow-1.0.75
+ arc-swap-1.6.0
+ autocfg-1.1.0
+ bitflags-1.3.2
+ bitflags-2.4.0
+ bstr-1.6.0
+ btoi-0.4.3
+ bzip2-rs-0.1.2
+ cc-1.0.82
+ cfg-if-1.0.0
+ clap-4.3.23
+ clap_builder-4.3.23
+ clap_lex-0.5.0
+ clru-0.6.1
+ colorchoice-1.0.0
+ crc32fast-1.3.2
+ ctrlc-3.4.0
+ curl-0.4.44
+ curl-sys-0.4.65+curl-8.2.1
+ deranged-0.3.7
+ dunce-1.0.4
+ encoding_rs-0.8.32
+ equivalent-1.0.1
+ errno-0.3.2
+ errno-dragonfly-0.1.2
+ fastrand-2.0.0
+ filetime-0.2.22
+ flate2-1.0.27
+ form_urlencoded-1.2.0
+ getrandom-0.2.10
+ gix-0.51.0
+ gix-actor-0.24.2
+ gix-attributes-0.16.0
+ gix-bitmap-0.2.6
+ gix-chunk-0.4.4
+ gix-command-0.2.8
+ gix-commitgraph-0.18.2
+ gix-config-0.26.2
+ gix-config-value-0.12.5
+ gix-credentials-0.17.1
+ gix-date-0.7.2
+ gix-diff-0.33.1
+ gix-discover-0.22.1
+ gix-features-0.32.1
+ gix-filter-0.2.0
+ gix-fs-0.4.1
+ gix-glob-0.10.2
+ gix-hash-0.11.4
+ gix-hashtable-0.2.4
+ gix-ignore-0.5.1
+ gix-index-0.21.1
+ gix-lock-7.0.2
+ gix-mailmap-0.16.1
+ gix-negotiate-0.5.1
+ gix-object-0.33.2
+ gix-odb-0.50.2
+ gix-pack-0.40.2
+ gix-packetline-blocking-0.16.4
+ gix-path-0.8.4
+ gix-prompt-0.5.5
+ gix-quote-0.4.6
+ gix-ref-0.33.3
+ gix-refspec-0.14.1
+ gix-revision-0.18.1
+ gix-revwalk-0.4.1
+ gix-sec-0.8.4
+ gix-tempfile-7.0.2
+ gix-trace-0.1.3
+ gix-traverse-0.30.1
+ gix-url-0.21.1
+ gix-utils-0.1.5
+ gix-validate-0.7.7
+ gix-worktree-0.23.1
+ hashbrown-0.12.3
+ hashbrown-0.14.0
+ hermit-abi-0.3.2
+ hex-0.4.3
+ home-0.5.5
+ idna-0.4.0
+ imara-diff-0.1.5
+ indexmap-2.0.0
+ io-close-0.3.7
+ io-lifetimes-1.0.11
+ is-terminal-0.4.9
+ itoa-1.0.9
+ kstring-2.0.0
+ libc-0.2.147
+ libz-sys-1.1.12
+ linux-raw-sys-0.3.8
+ linux-raw-sys-0.4.5
+ lock_api-0.4.10
+ log-0.4.20
+ memchr-2.5.0
+ memmap2-0.7.1
+ minimal-lexical-0.2.1
+ miniz_oxide-0.7.1
+ nix-0.26.2
+ nom-7.1.3
+ num-traits-0.2.16
+ num_threads-0.1.6
+ once_cell-1.18.0
+ openssl-probe-0.1.5
+ openssl-sys-0.9.91
+ parking_lot-0.12.1
+ parking_lot_core-0.9.8
+ percent-encoding-2.3.0
+ pkg-config-0.3.27
+ proc-macro2-1.0.66
+ prodash-25.0.1
+ quote-1.0.33
+ redox_syscall-0.3.5
+ regex-automata-0.3.6
+ rustix-0.37.23
+ rustix-0.38.8
+ ryu-1.0.15
+ same-file-1.0.6
+ schannel-0.1.22
+ scopeguard-1.2.0
+ serde-1.0.171
+ serde_derive-1.0.171
+ serde_json-1.0.105
+ sha1_smol-1.0.0
+ signal-hook-0.3.17
+ signal-hook-registry-1.4.1
+ smallvec-1.11.0
+ socket2-0.4.9
+ static_assertions-1.1.0
+ strsim-0.10.0
+ syn-2.0.29
+ tar-0.4.40
+ tempfile-3.8.0
+ termcolor-1.2.0
+ terminal_size-0.2.6
+ thiserror-1.0.47
+ thiserror-impl-1.0.47
+ time-0.3.26
+ time-core-0.1.1
+ time-macros-0.2.12
+ tinyvec-1.6.0
+ tinyvec_macros-0.1.1
+ unicode-bidi-0.3.13
+ unicode-bom-2.0.2
+ unicode-ident-1.0.11
+ unicode-normalization-0.1.22
+ url-2.4.0
+ utf8parse-0.2.1
+ vcpkg-0.2.15
+ version_check-0.9.4
+ walkdir-2.3.3
+ wasi-0.11.0+wasi-snapshot-preview1
+ winapi-0.3.9
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-util-0.1.5
+ winapi-x86_64-pc-windows-gnu-0.4.0
+ windows-0.48.0
+ windows-sys-0.48.0
+ windows-targets-0.48.5
+ windows_aarch64_gnullvm-0.48.5
+ windows_aarch64_msvc-0.48.5
+ windows_i686_gnu-0.48.5
+ windows_i686_msvc-0.48.5
+ windows_x86_64_gnu-0.48.5
+ windows_x86_64_gnullvm-0.48.5
+ windows_x86_64_msvc-0.48.5
+ winnow-0.5.14
+ xattr-1.0.1
+"
+
+inherit cargo flag-o-matic
+
+DESCRIPTION="Stack-based patch management for Git"
+HOMEPAGE="https://stacked-git.github.io/"
+SRC_URI="${CARGO_CRATE_URIS}"
+SRC_URI+=" https://github.com/stacked-git/stgit/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+# Dependent crate licenses
+LICENSE+=" Apache-2.0 BSD MIT Unicode-DFS-2016"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-text/asciidoc )"
+RDEPEND=""
+
+# rust does not use *FLAGS from make.conf, silence portage warning
+# update with proper path to binaries this crate installs, omit leading /
+QA_FLAGS_IGNORED="usr/bin/stg"
+
+src_configure() {
+ filter-lto #bug 897692
+}
+
+src_compile() {
+ cargo_src_compile
+ emake completion
+ emake contrib
+ use doc && emake doc
+}
+
+src_install() {
+ cargo_src_install
+ emake DESTDIR="${D}" prefix="/usr" install-completion
+ emake DESTDIR="${D}" prefix="/usr" install-contrib
+ if use doc; then
+ emake DESTDIR="${D}" prefix="/usr" install-man
+ emake DESTDIR="${D}" prefix="/usr" \
+ htmldir="/usr/share/doc/${PF}" \
+ install-html
+ fi
+}