summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/vcsh/vcsh-1.20141026.ebuild')
-rw-r--r--dev-vcs/vcsh/vcsh-1.20141026.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-vcs/vcsh/vcsh-1.20141026.ebuild b/dev-vcs/vcsh/vcsh-1.20141026.ebuild
new file mode 100644
index 000000000000..899fba1bf242
--- /dev/null
+++ b/dev-vcs/vcsh/vcsh-1.20141026.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION='Manage config files in $HOME via fake bare git repositories'
+HOMEPAGE="https://github.com/RichiH/vcsh/"
+SRC_URI="http://github.com/RichiH/vcsh/archive/v${PV}-manpage-static.tar.gz -> ${P}-manpage-static.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+DEPEND=""
+
+DOCS=( changelog README.md CONTRIBUTORS )
+
+S=${S}-manpage-static
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's,vendor-completions,site-functions,' \
+ -e "s,\(\$(DOCDIR_PREFIX)\)/\$(self),\1/${PF}," \
+ Makefile || die
+}
+
+src_install() {
+ default
+ dodoc -r doc/sample_hooks
+}