summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/repo/Manifest1
-rw-r--r--dev-vcs/repo/repo-2.40.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index a5c6cb208177..72b8ad2f0830 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1 +1,2 @@
DIST repo-2.37.tar.gz 273445 BLAKE2B 7934581c5c55896d8ba58f5841a028f4676062197498ef601fa005f4e19428eee552e66d057a1e0d033eff8691df2de8e130ff96aec0e4537a462be81796e249 SHA512 6aa11e9fc9d899866dd89788c94ef188ea89dc6757a4e4fe0f1284898315723f72b3b97b60d39194f34e56332057545eb9c99b6483bc3e0513f747410226b9fa
+DIST repo-2.40.tar.gz 277118 BLAKE2B 57ebd20e323a4c3d02885c71f599bf57d23e68b8199b136095ce77a479a815439c51844b11744e0c9555091e91821ba49715c57d985a3a30579497b4617b6361 SHA512 0cd9df29edf14acdaeb0e4d07dea13f6e3bfa77ac36ffe7c4042d050c5d3fb36a7ff9a249e521aef7d7e5fbff9fe1c4b94df02c0d435353e0c169a94254f78ba
diff --git a/dev-vcs/repo/repo-2.40.ebuild b/dev-vcs/repo/repo-2.40.ebuild
new file mode 100644
index 000000000000..3203603bb0c4
--- /dev/null
+++ b/dev-vcs/repo/repo-2.40.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://github.com/GerritCodeReview/git-repo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+"
+
+S="${WORKDIR}/git-${P}"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ newbashcomp completion.bash ${PN}
+ doman man/*.[0-9]
+}