summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvsps/cvsps-3.13-r2.ebuild (renamed from dev-vcs/cvsps/cvsps-3.13-r1.ebuild)10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-vcs/cvsps/cvsps-3.13-r1.ebuild b/dev-vcs/cvsps/cvsps-3.13-r2.ebuild
index 45e63d4b5dc4..1d9ca2cea5f5 100644
--- a/dev-vcs/cvsps/cvsps-3.13-r1.ebuild
+++ b/dev-vcs/cvsps/cvsps-3.13-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit eutils toolchain-funcs
@@ -20,10 +20,13 @@ DEPEND="${RDEPEND}
RESTRICT=test # upstream does not ship tests
+PATCHES=("${FILESDIR}"/${P}-make.patch)
+
src_prepare() {
+ default
+
local gentoo_name=${PN}-3
- epatch "${FILESDIR}"/${P}-make.patch
mv ${PN}.asc ${gentoo_name}.asc || die
sed -i "s/${PN}/${gentoo_name}/g" ${gentoo_name}.asc || die
sed -i "s/PROG = cvsps/PROG = ${gentoo_name}/" Makefile || die
@@ -34,5 +37,6 @@ src_prepare() {
src_install() {
default
+
dodoc README
}