summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/barrage/barrage-1.0.4-r1.ebuild')
-rw-r--r--games-action/barrage/barrage-1.0.4-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/games-action/barrage/barrage-1.0.4-r1.ebuild b/games-action/barrage/barrage-1.0.4-r1.ebuild
index 16aeec97af84..fc4dde6e54ed 100644
--- a/games-action/barrage/barrage-1.0.4-r1.ebuild
+++ b/games-action/barrage/barrage-1.0.4-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit eutils
DESCRIPTION="A violent point-and-click shooting game"
@@ -13,13 +14,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.2[sound,video]
+DEPEND="
+ >=media-libs/libsdl-1.2[sound,video]
>=media-libs/sdl-mixer-1.2.4"
RDEPEND="${DEPEND}"
src_install() {
default
+
newicon barrage48.png ${PN}.png
make_desktop_entry ${PN} Barrage
- rm "${D}"/usr/share/applications/${PN}.desktop
+ rm "${ED%/}"/usr/share/applications/${PN}.desktop || die
}