summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/garden')
-rw-r--r--games-action/garden/Manifest2
-rw-r--r--games-action/garden/files/garden-1.0.8-dash.patch33
-rw-r--r--games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch19
-rw-r--r--games-action/garden/files/garden-1.0.8-underlink.patch19
-rw-r--r--games-action/garden/files/garden-1.0.9-dash.patch33
-rw-r--r--games-action/garden/files/garden-1.0.9-resources.patch7
-rw-r--r--games-action/garden/garden-1.0.8-r1.ebuild48
-rw-r--r--games-action/garden/garden-1.0.9.ebuild47
-rw-r--r--games-action/garden/metadata.xml8
9 files changed, 216 insertions, 0 deletions
diff --git a/games-action/garden/Manifest b/games-action/garden/Manifest
new file mode 100644
index 000000000000..492e4c97a183
--- /dev/null
+++ b/games-action/garden/Manifest
@@ -0,0 +1,2 @@
+DIST garden-1.0.8.tar.gz 2666132 SHA256 3b882e3030838679af3ee40e51fb792ca48fa83799ac6d74f9565954d736ce69 SHA512 eb3f97853b158633533083ef7c475ff2487b484a1b42be133a22e7842a3abd8e306a5009c4da6a6b0ba2ab10a71c40660da237740fe7b2a0fa6378a9af1de7bd WHIRLPOOL bab3199190d170ac0ebddf65461546a688094feca65203ba408788653e7294984b46b55c7c3b1ab4e1e80f1218094c93694fb42b3657dd73ef14153ee723dd30
+DIST garden-1.0.9.tar.gz 2714783 SHA256 daf8732c229a4cc04f460514bff1ba05171faada9e19575c72a50a914f2352e3 SHA512 e8f52fc0ebf9eaa7933ae1faa5610e8a27a5e7cfc59d033714c4306a53680feeddd52b1fb3050f2d72addba03ee383e71e57eac02270f3d2369aed054a9a9848 WHIRLPOOL 77a8f3add973467a6f5d1ccc85fdcfd9ca2ea1e6a841c0c14b4860545a0aeaccbf3ae8934fde6045f5f3848d33fbe68f65773fffc07e8c3971e8a6b1d8373e7b
diff --git a/games-action/garden/files/garden-1.0.8-dash.patch b/games-action/garden/files/garden-1.0.8-dash.patch
new file mode 100644
index 000000000000..2d8630236ffb
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.8-dash.patch
@@ -0,0 +1,33 @@
+--- configure.ac.orig 2015-05-04 14:48:03.467935640 -0400
++++ configure.ac 2015-05-04 14:48:24.729199607 -0400
+@@ -80,7 +80,7 @@
+ [have_allegro="no"])
+ AC_MSG_RESULT([$have_allegro])
+ LIBS=$LIBS_SAVE
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [return 0],
+ [return 1])
+ }
+@@ -89,7 +89,7 @@
+ AM_PATH_ALLEGRO([4.2.0])
+
+ try_link_allegro "$allegro_LIBS"
+-AS_IF([test "x$?" == "x0"],
++AS_IF([test "x$?" = "x0"],
+ [[LIBS="$LIBS $allegro_LIBS"
+ ALLEGRO_LIB=`echo $allegro_LIBS | sed -e 's/-l\([^[:blank:]]*\).*/\1/'`
+ have_allegro="yes"]])
+@@ -103,10 +103,10 @@
+ for lib in $ALLEGRO_LIBS
+ do
+ ldflag="-l$lib"
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [break])
+ try_link_allegro $ldflag
+- AS_IF([test "x$?" == "x0"],
++ AS_IF([test "x$?" = "x0"],
+ [LIBS="$LIBS $ldflag"
+ ALLEGRO_LIB="$lib"
+ have_allegro="yes"])
diff --git a/games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch b/games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch
new file mode 100644
index 000000000000..69cff8fa319d
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch
@@ -0,0 +1,19 @@
+At least for autoconf-2.69 AS_INIT is called by AC_INIT.
+
+When using /bin/dash calling AS_INIT directly leads to infinite
+reexec loop.
+
+Gentoo-bug: http://bugs.gentoo.org/475248
+diff --git a/configure.ac b/configure.ac
+index eb0002f..6c77ef9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -5,7 +5,7 @@ AC_PREREQ(2.62)
+ AC_INIT([GARDEN],
+ [1.0.8],
+ [bubla@users.sourceforge.net])
+-AS_INIT
++
+ AC_CONFIG_AUX_DIR([build-aux])
+ AM_INIT_AUTOMAKE([-Wall])
+ AC_CONFIG_SRCDIR([src/input.h])
diff --git a/games-action/garden/files/garden-1.0.8-underlink.patch b/games-action/garden/files/garden-1.0.8-underlink.patch
new file mode 100644
index 000000000000..bd25a4d57384
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.8-underlink.patch
@@ -0,0 +1,19 @@
+--- bin/Makefile.am.old 2011-06-22 18:16:30.654661047 +0200
++++ bin/Makefile.am 2011-06-22 18:16:55.662251326 +0200
+@@ -9,6 +9,7 @@
+ garden_LDFLAGS = -static
+ else #unix version :-)
+ AM_CPPFLAGS = -D'DATADIR="@DATADIR_NAME@"'
++garden_LDADD = -lm
+ endif
+
+ #how to build resources?
+--- Makefile.am.old 2011-06-22 18:19:37.787560851 +0200
++++ Makefile.am 2011-06-22 18:19:44.078960907 +0200
+@@ -1,5 +1,5 @@
+ ACLOCAL_AMFLAGS= -I m4
+-SUBDIRS = bin resources
++SUBDIRS = bin
+
+ if NO_EXISTING_DATA
+ SUBDIRS += data
diff --git a/games-action/garden/files/garden-1.0.9-dash.patch b/games-action/garden/files/garden-1.0.9-dash.patch
new file mode 100644
index 000000000000..2d8630236ffb
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.9-dash.patch
@@ -0,0 +1,33 @@
+--- configure.ac.orig 2015-05-04 14:48:03.467935640 -0400
++++ configure.ac 2015-05-04 14:48:24.729199607 -0400
+@@ -80,7 +80,7 @@
+ [have_allegro="no"])
+ AC_MSG_RESULT([$have_allegro])
+ LIBS=$LIBS_SAVE
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [return 0],
+ [return 1])
+ }
+@@ -89,7 +89,7 @@
+ AM_PATH_ALLEGRO([4.2.0])
+
+ try_link_allegro "$allegro_LIBS"
+-AS_IF([test "x$?" == "x0"],
++AS_IF([test "x$?" = "x0"],
+ [[LIBS="$LIBS $allegro_LIBS"
+ ALLEGRO_LIB=`echo $allegro_LIBS | sed -e 's/-l\([^[:blank:]]*\).*/\1/'`
+ have_allegro="yes"]])
+@@ -103,10 +103,10 @@
+ for lib in $ALLEGRO_LIBS
+ do
+ ldflag="-l$lib"
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [break])
+ try_link_allegro $ldflag
+- AS_IF([test "x$?" == "x0"],
++ AS_IF([test "x$?" = "x0"],
+ [LIBS="$LIBS $ldflag"
+ ALLEGRO_LIB="$lib"
+ have_allegro="yes"])
diff --git a/games-action/garden/files/garden-1.0.9-resources.patch b/games-action/garden/files/garden-1.0.9-resources.patch
new file mode 100644
index 000000000000..6acd6f5f78d5
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.9-resources.patch
@@ -0,0 +1,7 @@
+--- Makefile.am.orig 2015-05-04 16:57:07.510191036 -0400
++++ Makefile.am 2015-05-04 16:57:14.581946228 -0400
+@@ -1,3 +1,3 @@
+ ACLOCAL_AMFLAGS= -I m4
+
+-SUBDIRS = src resources data
++SUBDIRS = src data
diff --git a/games-action/garden/garden-1.0.8-r1.ebuild b/games-action/garden/garden-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..41ad07d0de32
--- /dev/null
+++ b/games-action/garden/garden-1.0.8-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils autotools games
+
+DESCRIPTION="Multiplatform vertical shoot-em-up with non-traditional elements"
+HOMEPAGE="http://garden.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="<media-libs/allegro-5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-dash.patch \
+ "${FILESDIR}"/${P}-drop-AS_INIT.patch #475248
+ eautoreconf
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README" \
+ default
+ doicon -s scalable resources/garden.svg
+ make_desktop_entry garden "Garden of coloured lights"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/garden/garden-1.0.9.ebuild b/games-action/garden/garden-1.0.9.ebuild
new file mode 100644
index 000000000000..62df12c7f80a
--- /dev/null
+++ b/games-action/garden/garden-1.0.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils autotools games
+
+DESCRIPTION="Multiplatform vertical shoot-em-up with non-traditional elements"
+HOMEPAGE="http://garden.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="<media-libs/allegro-5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-dash.patch \
+ "${FILESDIR}"/${P}-resources.patch
+ eautoreconf
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README" \
+ default
+ doicon -s scalable resources/garden.svg
+ make_desktop_entry garden "Garden of coloured lights"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/garden/metadata.xml b/games-action/garden/metadata.xml
new file mode 100644
index 000000000000..e6459c07f8a7
--- /dev/null
+++ b/games-action/garden/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">garden</remote-id>
+ </upstream>
+</pkgmetadata>