summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/supertuxkart/supertuxkart-1.4-r1.ebuild')
-rw-r--r--games-action/supertuxkart/supertuxkart-1.4-r1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/games-action/supertuxkart/supertuxkart-1.4-r1.ebuild b/games-action/supertuxkart/supertuxkart-1.4-r1.ebuild
index 7b2fcde8f196..85252331bd59 100644
--- a/games-action/supertuxkart/supertuxkart-1.4-r1.ebuild
+++ b/games-action/supertuxkart/supertuxkart-1.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake desktop xdg
+inherit cmake desktop flag-o-matic xdg
MY_P="SuperTuxKart-${PV}-src"
DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
@@ -59,6 +59,17 @@ PATCHES=(
)
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858521
+ # https://github.com/supertuxkart/stk-code/issues/5035
+ #
+ # The issue is bundled code from sci-physics/bullet which is unlikely to
+ # be debundled.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DUSE_SQLITE3=$(usex sqlite)
-DUSE_SYSTEM_ANGELSCRIPT=ON