summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/xblast')
-rw-r--r--games-action/xblast/files/xblast-2.10.4-gcc-10.patch22
-rw-r--r--games-action/xblast/xblast-2.10.4-r1.ebuild6
2 files changed, 27 insertions, 1 deletions
diff --git a/games-action/xblast/files/xblast-2.10.4-gcc-10.patch b/games-action/xblast/files/xblast-2.10.4-gcc-10.patch
new file mode 100644
index 000000000000..01d6da9bd13e
--- /dev/null
+++ b/games-action/xblast/files/xblast-2.10.4-gcc-10.patch
@@ -0,0 +1,22 @@
+--- a/cfg_control.h
++++ b/cfg_control.h
+@@ -29,7 +29,7 @@
+ #define NUM_KEYB_CONTROLS 2
+
+ /* constant assignment of control to event type */
+-const XBEventCode keyEventType[NUM_KEYB_CONTROLS];
++extern const XBEventCode keyEventType[NUM_KEYB_CONTROLS];
+
+ /* ingame controls for editing*/
+ typedef struct
+--- a/network.h
++++ b/network.h
+@@ -105,7 +105,7 @@ typedef enum
+ #define TEAM_UNDEF 252
+
+ /* team color assignment */
+-const XBColor teamColors[NUM_XBTS];
++extern const XBColor teamColors[NUM_XBTS];
+
+ /* results of game config receive/create */
+ typedef enum
diff --git a/games-action/xblast/xblast-2.10.4-r1.ebuild b/games-action/xblast/xblast-2.10.4-r1.ebuild
index 72666813a3c4..3da27dd600ac 100644
--- a/games-action/xblast/xblast-2.10.4-r1.ebuild
+++ b/games-action/xblast/xblast-2.10.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,6 +32,10 @@ RDEPEND="
DEPEND="${RDEPEND}
x11-libs/libXt"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-10.patch
+)
+
src_prepare() {
default