summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action')
-rw-r--r--games-action/shootingstar/files/1.2.0-gcc34.patch23
-rw-r--r--games-action/shootingstar/files/shootingstar-1.2.0-basic-fixes.patch29
-rw-r--r--games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch10
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0-r1.ebuild53
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0-r2.ebuild44
5 files changed, 73 insertions, 86 deletions
diff --git a/games-action/shootingstar/files/1.2.0-gcc34.patch b/games-action/shootingstar/files/1.2.0-gcc34.patch
deleted file mode 100644
index b55997552fc8..000000000000
--- a/games-action/shootingstar/files/1.2.0-gcc34.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -ur shootingstar-1.2.0/src/engine/cTextureFont.cpp shootingstar-1.2.0.loz/src/engine/cTextureFont.cpp
---- shootingstar-1.2.0/src/engine/cTextureFont.cpp 2003-07-06 19:31:10.000000000 +0100
-+++ shootingstar-1.2.0.loz/src/engine/cTextureFont.cpp 2004-07-26 20:51:16.992768063 +0100
-@@ -31,6 +31,7 @@
- #include <stdio.h>
- #include <GL/gl.h>
- #include <GL/glu.h>
-+#include <math.h>
- #include "cTextureManager.hpp"
- #include "Debug.hpp"
- //------------------------------------------------------------------------------
-diff -ur shootingstar-1.2.0/src/game/cOptions.cpp shootingstar-1.2.0.loz/src/game/cOptions.cpp
---- shootingstar-1.2.0/src/game/cOptions.cpp 2003-12-22 05:09:06.000000000 +0000
-+++ shootingstar-1.2.0.loz/src/game/cOptions.cpp 2004-07-26 21:00:25.265284270 +0100
-@@ -201,7 +201,7 @@
- dbgError () << "Unable to read from options file\n";
- throw runtime_error ("Unable to load options");
- }
-- int (keys.keys[i]) = key; // IS THIS SAFE?
-+ keys.keys[i] = (SDLKey)key; // IS THIS SAFE?
-
- fin >> key;
- keys.buttons[i] = key;
diff --git a/games-action/shootingstar/files/shootingstar-1.2.0-basic-fixes.patch b/games-action/shootingstar/files/shootingstar-1.2.0-basic-fixes.patch
new file mode 100644
index 000000000000..48304070d5c8
--- /dev/null
+++ b/games-action/shootingstar/files/shootingstar-1.2.0-basic-fixes.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/58287 (math.h/SDLKey for gcc 3.4)
+https://bugs.gentoo.org/272374 (cstdio for gcc 4.4)
+https://bugs.gentoo.org/607428 (signed int for segfault)
+--- a/src/engine/cTextureFont.cpp
++++ b/src/engine/cTextureFont.cpp
+@@ -33,2 +33,3 @@
+ #include <GL/glu.h>
++#include <math.h>
+ #include "cTextureManager.hpp"
+--- a/src/engine/dbg.cpp
++++ b/src/engine/dbg.cpp
+@@ -26,2 +26,3 @@
+ #include <cstdlib>
++#include <cstdio>
+ #include <string>
+--- a/src/game/cMainMenu.cpp
++++ b/src/game/cMainMenu.cpp
+@@ -401,3 +401,3 @@
+
+- static unsigned int i = 0;
++ static int i = 0;
+ if ( mLastLetter + 100 < now )
+--- a/src/game/cOptions.cpp
++++ b/src/game/cOptions.cpp
+@@ -203,3 +203,3 @@
+ }
+- int (keys.keys[i]) = key; // IS THIS SAFE?
++ keys.keys[i] = (SDLKey)key;
+
diff --git a/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch b/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
deleted file mode 100644
index dfc1a8d8e77e..000000000000
--- a/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/engine/dbg.cpp 2009-06-03 15:15:46.000000000 +0200
-+++ b/src/engine/dbg.cpp 2009-06-03 16:09:19.000000000 +0200
-@@ -28,6 +28,7 @@
- #include <vector>
- #include <map>
- #include <algorithm>
-+#include <cstdio>
-
- /**********************************************************************
- * Implementation notes
diff --git a/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild b/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild
deleted file mode 100644
index 014fc4fb2580..000000000000
--- a/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools desktop gnome2-utils
-
-# Note: currently segfaults on startup, but that's also in the previous ebuild
-# See https://bugs.gentoo.org/607428
-
-DESCRIPTION="A topdown shooter"
-HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Arcade/Shooting-Star-19754.shtml"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- media-libs/libsdl[video]
- media-libs/sdl-image
- media-libs/sdl-mixer
- virtual/glu
- virtual/opengl"
-RDEPEND=${DEPEND}
-
-PATCHES=(
- "${FILESDIR}"/${PV}-gcc34.patch
- "${FILESDIR}"/${P}-gcc44.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_install() {
- default
- newicon -s 128 data/textures/body1.png ${PN}.png
- make_desktop_entry ${PN} "Shooting Star"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-action/shootingstar/shootingstar-1.2.0-r2.ebuild b/games-action/shootingstar/shootingstar-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..7885724a6b03
--- /dev/null
+++ b/games-action/shootingstar/shootingstar-1.2.0-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop toolchain-funcs
+
+DESCRIPTION="A topdown shooter"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[opengl,sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-basic-fixes.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newicon data/textures/body1.png ${PN}.png
+ make_desktop_entry ${PN} "Shooting Star"
+}