summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action')
-rw-r--r--games-action/descent1-freedata/Manifest4
-rw-r--r--games-action/descent1-freedata/descent1-freedata-1.ebuild58
-rw-r--r--games-action/descent1-freedata/metadata.xml35
3 files changed, 97 insertions, 0 deletions
diff --git a/games-action/descent1-freedata/Manifest b/games-action/descent1-freedata/Manifest
new file mode 100644
index 000000000000..8580b3528ec5
--- /dev/null
+++ b/games-action/descent1-freedata/Manifest
@@ -0,0 +1,4 @@
+DIST d1xr-briefings-ger.dxa 16798 BLAKE2B f5e1f4f91cb3464b3d356fab1e3993700cc19f3f2db8682f5194e59aa5d2623efa427db4135c3595534e5dac0f2589b53aac7df3610501b759407e1ead342458 SHA512 956a3ef1fe7379b71d5f651fdcb1f26b786883a35193a0a22009204e885a12fceb3a69c6accbeb2bd20be65afe087d23532d7ef3439edd97cc8904968bf519e3
+DIST d1xr-hires.dxa 1426884 BLAKE2B c4d9b950353fc450c64568779bc3d2e93a46e17980c8df08a2ef06bff5b9709869fdbbaf4fb6698be994b3faae7a75036a53357743d47b728bb3ef9df126afd8 SHA512 3fc84d5610ba40ee383c1720f80513a21b4644ff8b6da4b84ebca13b11c1131deb4897ded6324b54845b6c847dfc0f16700535e16afdd7ebe83bfff042892302
+DIST d1xr-opl3-music.dxa 81503503 BLAKE2B b560597e0f08139109a6dc4ee7996c05010561686029d1fd754375278b8a11e6df0f6106c797d524e92d4998683d6e1e07b6cfc982ea3ff167a0b9ca92ba0dc2 SHA512 4ac82c4bc2ddb02e2941746921443e38b698c6e54cfcab317fc9108f84ada7b868ec2ee3c70b28c1dfe9f41e2aadab4124c8daa65a409905cba5d674f0aab8a8
+DIST d1xr-sc55-music.dxa 72803408 BLAKE2B eb52491f5c43e9f04aea5715cffc0a47d029dda0b8e5ae1a79ec36122a17c01e3b2a731f369d72fe0e069e1188bdaf03f82d0845b574d76b6798be33481e3b84 SHA512 3cdce5b6535e28397b3216cc9ca05cccf7194349c62d64c54300f02f39248b98598d170599e5c61b6900d780e4917f905c3c31eb814fbb8429221c804cbd8bf9
diff --git a/games-action/descent1-freedata/descent1-freedata-1.ebuild b/games-action/descent1-freedata/descent1-freedata-1.ebuild
new file mode 100644
index 000000000000..6339583ee80b
--- /dev/null
+++ b/games-action/descent1-freedata/descent1-freedata-1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 DXX Rebirth project contributors
+# Distributed under the terms of the GNU General Public License v2
+
+# This file is part of the DXX-Rebirth project.
+#
+# It is copyright by its individual contributors, as recorded in the
+# project's Git history. See COPYING.txt at the top level for license
+# terms and a link to the Git history.
+
+EAPI=7
+
+DXX_ENGINE="${PN:7:1}"
+DESCRIPTION="Free content for games-action/d${DXX_ENGINE}x-rebirth"
+HOMEPAGE="https://www.dxx-rebirth.com/"
+IUSE="l10n_de opl3-musicpack sc55-musicpack"
+SRC_URI="
+ l10n_de? ( https://www.dxx-rebirth.com/download/dxx/res/d${DXX_ENGINE}xr-briefings-ger.dxa )
+ opl3-musicpack? ( https://www.dxx-rebirth.com/download/dxx/res/d${DXX_ENGINE}xr-opl3-music.dxa )
+ sc55-musicpack? ( https://www.dxx-rebirth.com/download/dxx/res/d${DXX_ENGINE}xr-sc55-music.dxa )
+"
+
+if [[ "${PN}" = descent1-freedata ]]; then
+ IUSE+=" +textures"
+ SRC_URI+="
+ textures? ( https://www.dxx-rebirth.com/download/dxx/res/d1xr-hires.dxa )
+"
+fi
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="$WORKDIR"
+
+# If all USE flags are unset, this ebuild installs zero files. Require
+# at least one to be set.
+REQUIRED_USE="|| ( ${IUSE//+/} )"
+
+RDEPEND="
+ !<games-action/dxx-rebirth-0.60
+ !games-action/d${DXX_ENGINE}x-rebirth
+ "
+
+unset DXX_ENGINE
+
+src_install() {
+ local DXX_ENGINE="${PN:7:1}"
+ insinto /usr/share/games/d${DXX_ENGINE}x
+ use opl3-musicpack && doins "${DISTDIR}"/d${DXX_ENGINE}xr-opl3-music.dxa
+ use sc55-musicpack && doins "${DISTDIR}"/d${DXX_ENGINE}xr-sc55-music.dxa
+ use l10n_de && doins "${DISTDIR}"/d${DXX_ENGINE}xr-briefings-ger.dxa
+
+ # This ebuild is used for both Descent 1 free data and Descent 2
+ # free data. Only Descent 1 provides alternate textures.
+ if [[ "${PN}" = descent1-freedata ]] && use textures; then
+ insinto /usr/share/games/d1x
+ doins "${DISTDIR}"/d1xr-hires.dxa
+ fi
+}
diff --git a/games-action/descent1-freedata/metadata.xml b/games-action/descent1-freedata/metadata.xml
new file mode 100644
index 000000000000..c1aebfb8b109
--- /dev/null
+++ b/games-action/descent1-freedata/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>iansilvester@fastmail.fm</email>
+ <name>Ian Silvester</name>
+ </maintainer>
+ <longdescription>
+ Descent 1 is a classic first-person shooter released in 1995
+ by Interplay and Parallax. Descent 2 released for the PC in
+ 1996. It, along with its predecessor, was one of the first
+ games with true 3-dimensional graphics, 6 degrees of freedom
+ in movement, light sourcing, and the capability to join
+ multiplayer games on-the-fly. D1X-Rebirth and DXX-Rebirth are
+ modifications of the original Descent 1 and 2 sources that was
+ released by Parallax (and are based on the D1X and D2X
+ sources). It offering OpenGL graphics, advanced multiplayer,
+ new features, and cross-platform compatibility. Now code bases
+ of D1X-Rebirth and DXX-Rebirth merged and released as
+ DXX-Rebirth. This package provides the free level data.
+ </longdescription>
+ <use>
+ <flag name="l10n_de">Provides German translations for the game's briefings, robot descriptions, and outro of the original campaign</flag>
+ <flag name="opl3-musicpack">Include alternate version of the game's music, recorded with the Yamaha YMF262 OPL3 soundchip</flag>
+ <flag name="sc55-musicpack">Include alternate version of the game's music, recorded with the Roland Sound Canvas SC-55 MIDI module</flag>
+ <flag name="textures">Include high resolution (640x480) backgrounds, briefing images and fonts (Descent 1)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">dxx-rebirth/dxx-rebirth</remote-id>
+ </upstream>
+</pkgmetadata>