summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action')
-rw-r--r--games-action/deathchase3d/deathchase3d-0.9-r1.ebuild27
-rw-r--r--games-action/deathchase3d/files/deathchase3d-0.9-underlink.patch4
2 files changed, 29 insertions, 2 deletions
diff --git a/games-action/deathchase3d/deathchase3d-0.9-r1.ebuild b/games-action/deathchase3d/deathchase3d-0.9-r1.ebuild
new file mode 100644
index 000000000000..562897841eb5
--- /dev/null
+++ b/games-action/deathchase3d/deathchase3d-0.9-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A remake of the Sinclair Spectrum game of the same name"
+HOMEPAGE="http://www.autismuk.freeserve.co.uk/"
+SRC_URI="http://www.autismuk.freeserve.co.uk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}/${P}-underlink.patch"
+)
+
+src_install() {
+ dobin "${PN}/${PN}"
+ dodoc README ${PN}/docs/en/index.html
+}
diff --git a/games-action/deathchase3d/files/deathchase3d-0.9-underlink.patch b/games-action/deathchase3d/files/deathchase3d-0.9-underlink.patch
index 79d1f69c7525..ac20e1ff3800 100644
--- a/games-action/deathchase3d/files/deathchase3d-0.9-underlink.patch
+++ b/games-action/deathchase3d/files/deathchase3d-0.9-underlink.patch
@@ -1,5 +1,5 @@
---- deathchase3d/Makefile.in.old 2011-06-13 09:22:44.140587725 +0200
-+++ deathchase3d/Makefile.in 2011-06-13 09:22:49.932942379 +0200
+--- a/deathchase3d/Makefile.in 2011-06-13 09:22:44.140587725 +0200
++++ b/deathchase3d/Makefile.in 2011-06-13 09:22:49.932942379 +0200
@@ -248,7 +248,7 @@
bin_PROGRAMS = deathchase3d