summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/amphetamine/amphetamine-0.8.10.ebuild')
-rw-r--r--games-arcade/amphetamine/amphetamine-0.8.10.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-arcade/amphetamine/amphetamine-0.8.10.ebuild b/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
new file mode 100644
index 000000000000..73d9b27173cc
--- /dev/null
+++ b/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="a cool Jump'n Run game offering some unique visual effects"
+HOMEPAGE="http://homepage.hispeed.ch/loehrer/amph/amph.html"
+SRC_URI="http://homepage.hispeed.ch/loehrer/amph/files/${P}.tar.bz2
+ http://homepage.hispeed.ch/loehrer/amph/files/${PN}-data-0.8.6.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-64bit.patch
+)
+
+src_compile() {
+ emake INSTALL_DIR="${GAMES_DATADIR}"/${PN}
+}
+
+src_install() {
+ newgamesbin amph ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../amph/*
+ newicon amph.xpm ${PN}.xpm
+ make_desktop_entry ${PN} Amphetamine ${PN}
+ dodoc BUGS ChangeLog NEWS README
+ prepgamesdirs
+}