summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/ascii-invaders/ascii-invaders-0.1b.ebuild')
-rw-r--r--games-arcade/ascii-invaders/ascii-invaders-0.1b.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-arcade/ascii-invaders/ascii-invaders-0.1b.ebuild b/games-arcade/ascii-invaders/ascii-invaders-0.1b.ebuild
new file mode 100644
index 000000000000..e3b3c1aaa99f
--- /dev/null
+++ b/games-arcade/ascii-invaders/ascii-invaders-0.1b.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="Space invaders clone, using ncurses library"
+HOMEPAGE="http://packages.gentoo.org/package/games-arcade/ascii-invaders"
+SRC_URI="mirror://gentoo/invaders${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/invaders
+
+src_prepare() {
+ rm -f Makefile
+}
+
+src_compile() {
+ emake LDLIBS="$(pkg-config ncurses --libs)" invaders
+}
+
+src_install() {
+ newgamesbin invaders ${PN}
+ dodoc TODO
+ prepgamesdirs
+}