summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/asteroid/asteroid-1.1.ebuild')
-rw-r--r--games-arcade/asteroid/asteroid-1.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games-arcade/asteroid/asteroid-1.1.ebuild b/games-arcade/asteroid/asteroid-1.1.ebuild
index 5e951998fcee..2ffbe944acf4 100644
--- a/games-arcade/asteroid/asteroid-1.1.ebuild
+++ b/games-arcade/asteroid/asteroid-1.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils games
DESCRIPTION="A modern version of the arcade classic that uses OpenGL"
@@ -19,12 +19,14 @@ DEPEND="virtual/opengl
virtual/glu
media-libs/libsdl
media-libs/sdl-mixer"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
-PATCHES=( "${FILESDIR}"/${P}-include.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+}
src_install() {
- emake DESTDIR="${D}" install
- dodoc asteroid-{authors,changes,readme}.txt
+ DOCS="$(echo asteroid-{authors,changes,readme}.txt)" \
+ default
prepgamesdirs
}