summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/batrachians/batrachians-0.1.7.ebuild')
-rw-r--r--games-arcade/batrachians/batrachians-0.1.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-arcade/batrachians/batrachians-0.1.7.ebuild b/games-arcade/batrachians/batrachians-0.1.7.ebuild
new file mode 100644
index 000000000000..059c43550bc8
--- /dev/null
+++ b/games-arcade/batrachians/batrachians-0.1.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="A fly-eating frog video game"
+HOMEPAGE="http://perso.b2b2c.ca/~sarrazip/dev/batrachians.html"
+SRC_URI="http://perso.b2b2c.ca/~sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-games/flatzebra-0.1.5
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.1.7-autotools.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}