summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/cob/cob-0.9-r2.ebuild')
-rw-r--r--games-arcade/cob/cob-0.9-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-arcade/cob/cob-0.9-r2.ebuild b/games-arcade/cob/cob-0.9-r2.ebuild
new file mode 100644
index 000000000000..b45c2ee9e74b
--- /dev/null
+++ b/games-arcade/cob/cob-0.9-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Cruising on Broadway: a painting-type game"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="
+ mirror://gentoo/${P}.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+
+RDEPEND="media-libs/libsdl[joystick,sound,video]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
+
+src_install() {
+ default
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} "Cruising on Broadway"
+}