summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/cob')
-rw-r--r--games-arcade/cob/Manifest1
-rw-r--r--games-arcade/cob/cob-0.9.ebuild29
-rw-r--r--games-arcade/cob/files/cob-0.9-gcc43.patch26
-rw-r--r--games-arcade/cob/files/cob-0.9-gcc44.patch30
-rw-r--r--games-arcade/cob/metadata.xml5
5 files changed, 91 insertions, 0 deletions
diff --git a/games-arcade/cob/Manifest b/games-arcade/cob/Manifest
new file mode 100644
index 000000000000..cf7ef0b556fc
--- /dev/null
+++ b/games-arcade/cob/Manifest
@@ -0,0 +1 @@
+DIST cob-0.9.tar.gz 712618 SHA256 e065bc5a3dabb7c4709cbfc4c44e683c815b95c2a0c4d80d26feb3e4833cf60e SHA512 1a329bb06a25137c1dc9d65cff949ed1b0ca7445ecf897375be71581c35f0bc563008fc7607d650a660a405f2282b0329148487bd29b6a053478b61d932bdf4d WHIRLPOOL 58932942761cec6cf8df27bea86b84786c6655c263fb58c55dcb826901879f0e3501dbf010d7784c2780c881574a0995e1a705f90fcce7fb4286099949f43fd1
diff --git a/games-arcade/cob/cob-0.9.ebuild b/games-arcade/cob/cob-0.9.ebuild
new file mode 100644
index 000000000000..b1812b28dc82
--- /dev/null
+++ b/games-arcade/cob/cob-0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Cruising on Broadway: a painting-type game"
+HOMEPAGE="http://www.autismuk.freeserve.co.uk/"
+SRC_URI="http://www.autismuk.freeserve.co.uk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[joystick,sound,video]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}
diff --git a/games-arcade/cob/files/cob-0.9-gcc43.patch b/games-arcade/cob/files/cob-0.9-gcc43.patch
new file mode 100644
index 000000000000..6b1f574628df
--- /dev/null
+++ b/games-arcade/cob/files/cob-0.9-gcc43.patch
@@ -0,0 +1,26 @@
+--- cob/menu.cpp
++++ cob/menu.cpp
+@@ -16,6 +16,7 @@
+ ***************************************************************************/
+
+ #include "cob.hxx"
++#include <cstring>
+
+ // **************************************************************************************************************************
+ //
+--- cob/sdw.hxx
++++ cob/sdw.hxx
+@@ -19,6 +19,7 @@
+
+ #include <iostream>
+ #include <string>
++#include <cstdlib>
+
+ namespace SDLWrapper // It's all nicely in a namespace SDLWrapper
+ {
+@@ -192,4 +193,4 @@
+ AudioNoise(int l) : AudioBeep(0,l) { }
+ };
+
+-};
++}
diff --git a/games-arcade/cob/files/cob-0.9-gcc44.patch b/games-arcade/cob/files/cob-0.9-gcc44.patch
new file mode 100644
index 000000000000..dd90b388e6d8
--- /dev/null
+++ b/games-arcade/cob/files/cob-0.9-gcc44.patch
@@ -0,0 +1,30 @@
+--- cob/game.cpp
++++ cob/game.cpp
+@@ -15,6 +15,7 @@
+ * *
+ ***************************************************************************/
+
++#include <cstdio>
+ #include "cob.hxx"
+
+ // **************************************************************************************************************************
+--- cob/main.cpp
++++ cob/main.cpp
+@@ -15,6 +15,7 @@
+ * *
+ ***************************************************************************/
+
++#include <cstdio>
+ #include "cob.hxx"
+
+ // **************************************************************************************************************************
+--- cob/map.cpp
++++ cob/map.cpp
+@@ -15,6 +15,7 @@
+ * *
+ ***************************************************************************/
+
++#include <cstdio>
+ #include "cob.hxx"
+
+ // **************************************************************************************************************************
diff --git a/games-arcade/cob/metadata.xml b/games-arcade/cob/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/cob/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>