summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/cosmosmash/cosmosmash-1.4.8.ebuild')
-rw-r--r--games-arcade/cosmosmash/cosmosmash-1.4.8.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/games-arcade/cosmosmash/cosmosmash-1.4.8.ebuild b/games-arcade/cosmosmash/cosmosmash-1.4.8.ebuild
index 7ca6cd6f8ad0..3c08d0bb90da 100644
--- a/games-arcade/cosmosmash/cosmosmash-1.4.8.ebuild
+++ b/games-arcade/cosmosmash/cosmosmash-1.4.8.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="A space rock shooting video game"
@@ -11,27 +12,31 @@ SRC_URI="http://perso.b2b2c.ca/~sarrazip/dev/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RESTRICT="test" # uses the sound card which portage user might not be available.
-RDEPEND=">=dev-games/flatzebra-0.1.7"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+RDEPEND=">=dev-games/flatzebra-0.1.7
+ media-libs/libsdl[joystick]
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
+
sed -i \
-e "/^pkgsounddir/ s:sounds.*:\$(PACKAGE)/sounds:" \
-e "/^desktopentrydir/ s:=.*:=/usr/share/applications:" \
-e "/^pixmapdir/ s:=.*:=/usr/share/pixmaps:" \
src/Makefile.am \
|| die
+
eautoreconf
}
src_install() {
emake -C src DESTDIR="${D}" install
+
einstalldocs
doman doc/${PN}.6
}