summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/fishsupper/fishsupper-0.1.6.ebuild')
-rw-r--r--games-arcade/fishsupper/fishsupper-0.1.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-arcade/fishsupper/fishsupper-0.1.6.ebuild b/games-arcade/fishsupper/fishsupper-0.1.6.ebuild
new file mode 100644
index 000000000000..667fd00a28f9
--- /dev/null
+++ b/games-arcade/fishsupper/fishsupper-0.1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools games
+
+DESCRIPTION="A simple arcade/puzzle game, loosely based on the retro classic Frogger"
+HOMEPAGE="http://sourceforge.net/projects/fishsupper/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="CC-BY-SA-2.5 GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[sound,video,opengl,X]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[wav]
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ovflfix.patch \
+ "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon data/images/fs_sprite_042.png ${PN}.png
+ make_desktop_entry ${PN} "Fish Supper"
+
+ prepgamesdirs
+}