summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/mari0')
-rw-r--r--games-arcade/mari0/Manifest2
-rw-r--r--games-arcade/mari0/mari0-1.6.ebuild63
-rw-r--r--games-arcade/mari0/metadata.xml17
3 files changed, 82 insertions, 0 deletions
diff --git a/games-arcade/mari0/Manifest b/games-arcade/mari0/Manifest
new file mode 100644
index 000000000000..bb970aec9f48
--- /dev/null
+++ b/games-arcade/mari0/Manifest
@@ -0,0 +1,2 @@
+DIST mari0-1.6.zip 3625226 SHA256 b217134425527e879d5355eb7f51e29a60ad0e93550e5769b2f56c04a1f69037 SHA512 20004035141b80180e58a8d209b588273d2879742ca8d8d59b1d20f9e301d976e260574893ea41a290bab57eade0617c10880a4af00dc3b29329ac4805a8be6c WHIRLPOOL 8ffc36d25ceb0d893cda3d068e484194feb6117ed27e4ea3801553868bdd8be35bbf787320ba37962d81851eb83082c528a4449f55acaeeb9dd731e5ba029334
+DIST mari0.svg.gz 6572 SHA256 5c712f06bc47d7e34598880ad72d18290a8e3f66f7a4af6a5bd6ae7962068d83 SHA512 7c6239219f3fc721a4393ca55790375862d510f8fd04b5b23df6e401efb545b410c25737a3d67ef24c6a978184477d9e47109e3715640876abecdae50b7b733f WHIRLPOOL ccb7aa7fc7bc838d3877c332482a8f07ff9f034f241963e349a18bc673125e0a6b6e64020f45b82e9d181db61d44061bac017c81fa95288eabc6922811422e4e
diff --git a/games-arcade/mari0/mari0-1.6.ebuild b/games-arcade/mari0/mari0-1.6.ebuild
new file mode 100644
index 000000000000..e7b2b60f9cea
--- /dev/null
+++ b/games-arcade/mari0/mari0-1.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils gnome2-utils games
+
+MY_P=${P/-/_}
+
+DESCRIPTION="A mix from Nintendo's Super Mario Bros and Valve's Portal"
+HOMEPAGE="http://stabyourself.net/mari0/"
+SRC_URI="${P}.zip
+ mirror://gentoo/mari0.svg.gz"
+
+LICENSE="CC-BY-NC-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+RESTRICT="fetch" # unsure about legality of graphics
+
+RDEPEND=">=games-engines/love-0.8.0
+ media-libs/devil[gif,png]"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please download ${PN}-source.zip from:"
+ einfo "http://stabyourself.net/${PN}/#download"
+ einfo "Move it to ${DISTDIR} and rename it to ${P}.zip"
+ echo
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/love/${PN}
+
+ exeinto "${dir}"
+ doexe ${MY_P}.love
+
+ doicon -s scalable ${PN}.svg
+ games_make_wrapper ${PN} "love ${MY_P}.love" "${dir}"
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "${PN} savegames and configurations are stored in:"
+ elog "~/.local/share/love/${PN}/"
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-arcade/mari0/metadata.xml b/games-arcade/mari0/metadata.xml
new file mode 100644
index 000000000000..b3eb6f8172b3
--- /dev/null
+++ b/games-arcade/mari0/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <longdescription lang="en">
+ A complete from scratch recreation of Super Mario Bros. with a focus on
+ perfectly imitating the feel the 1985 classic gave us. Then give Mario
+ a portal gun, add puzzle game mechanics from Portal and there you go.
+ And if that wasn't crazy enough, play 4-player coop, with everyone
+ having their own Portal gun!
+ </longdescription>
+</pkgmetadata>
+