summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/openmortal/openmortal-0.7-r2.ebuild')
-rw-r--r--games-arcade/openmortal/openmortal-0.7-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-arcade/openmortal/openmortal-0.7-r2.ebuild b/games-arcade/openmortal/openmortal-0.7-r2.ebuild
new file mode 100644
index 000000000000..025e21b639ff
--- /dev/null
+++ b/games-arcade/openmortal/openmortal-0.7-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="A spoof of the famous Mortal Kombat game"
+HOMEPAGE="http://openmortal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ >=media-libs/freetype-2.4.0:2
+ dev-lang/perl
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-freetype.patch
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon data/gfx/icon.png ${PN}.png
+ make_desktop_entry ${PN} OpenMortal
+}