summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/oshu/oshu-9999.ebuild')
-rw-r--r--games-arcade/oshu/oshu-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/games-arcade/oshu/oshu-9999.ebuild b/games-arcade/oshu/oshu-9999.ebuild
index 5ebae7bfdcd6..cf543ede25bd 100644
--- a/games-arcade/oshu/oshu-9999.ebuild
+++ b/games-arcade/oshu/oshu-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake xdg
@@ -27,11 +27,19 @@ RDEPEND="
media-libs/sdl2-image
x11-libs/cairo
x11-libs/pango
- media-video/ffmpeg:=
+ >media-video/ffmpeg-5:=
"
DEPEND="${RDEPEND}"
+src_unpack() {
+ default
+
+ if [[ ${PV} = *9999 ]]; then
+ git-r3_src_unpack
+ fi
+}
+
src_prepare() {
if use osu-skin; then
eapply "${FILESDIR}/oshu-2.0.0-use_unpacked_osu-skin.patch"
@@ -43,8 +51,8 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- '-DOSHU_DEFAULT_SKIN='$(usex osu-skin 'osu' 'minimal')
- '-DOSHU_SKINS=minimal'$(usex osu-skin ';osu' '')
+ -DOSHU_DEFAULT_SKIN=$(usex osu-skin osu minimal)
+ -DOSHU_SKINS=minimal$(usev osu-skin ';osu')
)
cmake_src_configure