summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/sable')
-rw-r--r--games-arcade/sable/sable-1.0-r1.ebuild (renamed from games-arcade/sable/sable-1.0.ebuild)24
1 files changed, 10 insertions, 14 deletions
diff --git a/games-arcade/sable/sable-1.0.ebuild b/games-arcade/sable/sable-1.0-r1.ebuild
index acffef5fd373..9ff9a086c60e 100644
--- a/games-arcade/sable/sable-1.0.ebuild
+++ b/games-arcade/sable/sable-1.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=6
+inherit desktop
DESCRIPTION="A frantic 3D space shooter"
HOMEPAGE="http://jeuxlibres.net/showgame/sable.html"
@@ -18,26 +18,22 @@ DEPEND="virtual/opengl
media-libs/libsdl[joystick,opengl,sound,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_compile() {
- emake INSTALL_RESDIR="${GAMES_DATADIR}"
+ emake INSTALL_RESDIR="/usr/share"
}
src_install() {
- dogamesbin ${PN}
- insinto "${GAMES_DATADIR}"/${PN}
+ dobin ${PN}
+ insinto /usr/share/${PN}
doins -r models sfx textures
- dodoc ChangeLog README
+ einstalldocs
doicon "${DISTDIR}"/${PN}.png
make_desktop_entry ${PN} Sable
-
- prepgamesdirs
}