summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild')
-rw-r--r--games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
deleted file mode 100644
index 4417f38e1265..000000000000
--- a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils games
-
-DESCRIPTION="Rework of Sasteroids using SDL"
-HOMEPAGE="http://sdlsas.sourceforge.net/"
-SRC_URI="mirror://sourceforge/sdlsas/SDLSasteroids-${PV}.tar.gz"
-
-LICENSE="GPL-2 freedist"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="virtual/opengl
- media-libs/sdl-mixer
- media-libs/libsdl[sound,joystick,video]
- media-libs/sdl-image[png]
- media-libs/sdl-ttf"
-RDEPEND="${DEPEND}"
-S=${WORKDIR}/SDLSasteroids-${PV}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-ldflags.patch
- sed -i \
- -e 's/make /$(MAKE) /' \
- -e 's/--strip//' \
- Makefile || die
- sed -i \
- -e '/^CC/d' \
- -e 's/g++/$(CXX)/' \
- -e 's/CC/CXX/' \
- -e 's/CFLAGS/CXXFLAGS/' \
- src/Makefile || die
-}
-
-src_compile() {
- emake \
- GAMEDIR="${GAMES_DATADIR}/${PN}" \
- OPTS="${CXXFLAGS}"
-}
-
-src_install() {
- dodir /usr/share/man/man6/
- emake \
- GAMEDIR="${D}/${GAMES_DATADIR}/${PN}" \
- BINDIR="${D}/${GAMES_BINDIR}" \
- MANDIR="${D}/usr/share/man/" \
- install
- dodoc ChangeLog README README.xast TODO description
- prepgamesdirs
-}