summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/tecnoballz/tecnoballz-0.93.1.ebuild')
-rw-r--r--games-arcade/tecnoballz/tecnoballz-0.93.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-arcade/tecnoballz/tecnoballz-0.93.1.ebuild b/games-arcade/tecnoballz/tecnoballz-0.93.1.ebuild
new file mode 100644
index 000000000000..129dbb32ecb0
--- /dev/null
+++ b/games-arcade/tecnoballz/tecnoballz-0.93.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop
+
+DESCRIPTION="An exciting Brick Breaker"
+HOMEPAGE="http://linux.tlk.fr/games/TecnoballZ/"
+SRC_URI="https://github.com/brunonymous/tecnoballz/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/tinyxml
+ media-libs/libsdl[joystick]
+ media-libs/sdl-mixer[mikmod]
+ media-libs/sdl-image[png]
+ media-libs/libmikmod:0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ mkdir man/fr || die
+ mv man/${PN}.fr.6 man/fr/${PN}.6 || die
+ sed -i -e 's:\$(prefix)/games:\$(prefix)/bin:' src/Makefile.am || die
+ sed -i -e '/CXXFLAGS=/d' -e '/^else/d' configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ make_desktop_entry ${PN} Tecnoballz
+}