summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/berusky/berusky-1.7.1-r2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/games-arcade/berusky/berusky-1.7.1-r2.ebuild b/games-arcade/berusky/berusky-1.7.1-r2.ebuild
index c14feec00747..65f429dfe17f 100644
--- a/games-arcade/berusky/berusky-1.7.1-r2.ebuild
+++ b/games-arcade/berusky/berusky-1.7.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop gnome2
+inherit desktop flag-o-matic gnome2
DATAFILE="${PN}-data-1.7"
DESCRIPTION="Free logic game based on an ancient puzzle named Sokoban"
@@ -34,6 +34,14 @@ src_prepare() {
default
}
+src_configure() {
+ # https://bugs.gentoo.org/787287
+ # clashes with C++17's "std::byte" type
+ append-cxxflags -std=c++14
+
+ default
+}
+
src_install() {
gnome2_src_install