summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/iagno')
-rw-r--r--games-board/iagno/Manifest1
-rw-r--r--games-board/iagno/iagno-3.36.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/games-board/iagno/Manifest b/games-board/iagno/Manifest
index c74a1827671e..9f707981c6b4 100644
--- a/games-board/iagno/Manifest
+++ b/games-board/iagno/Manifest
@@ -1,2 +1,3 @@
DIST iagno-3.34.5.tar.xz 563824 BLAKE2B 6933c1ca3ab5a31eebf285be1fa0ba6da18c5564589ec7a3083426dd22d0f050fbf87ef75c5cdc1b5e93822aba58d576e10f12c81785689739abb81fee659467 SHA512 5994d834302e52072e540ac882e8a5e39197a9ddd04972209362965d841565d942d341c91decedd1d11289c09336e13157414209c8d2d5c6816365d17e8f9379
DIST iagno-3.34.8.tar.xz 565656 BLAKE2B cf06f9259b8f31d69c6f734c0239dc89432cd7a4082bcd451a9e02efe882bc6f5245454d7ab5e89e69d171a9e27f88c927435c06a48454e4a88bdbcfdd193a23 SHA512 b966b4d5baafe517de7e09a585703c1642139348d1b178702afbb8a31be1433f2bf3c20869525835e8d9e0bd3ed3cf6306e50eb453a5f78f2ac1189cf0c3e90b
+DIST iagno-3.36.4.tar.xz 799480 BLAKE2B 430aa403c974728b929a7715e783dd594f00300dd9b0bf8b6f84da7265e31536a5cae17db94bcbdbebe3ef2690cb05bf18292af158016ec18bb695e58ca20f3d SHA512 43775149f76904a19316e5eac990d8dae0a730c3f6798ad88648892d4795b6892a86fb93b78a72fd30853ad36cc5e4b241e1cbd4067c78d6648f1630543f87be
diff --git a/games-board/iagno/iagno-3.36.4.ebuild b/games-board/iagno/iagno-3.36.4.ebuild
new file mode 100644
index 000000000000..d082dd5d6cad
--- /dev/null
+++ b/games-board/iagno/iagno-3.36.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.44"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Dominate the board in a classic version of Reversi"
+HOMEPAGE="https://wiki.gnome.org/Apps/Reversi"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.42.0:2
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.24.0:3
+ >=gnome-base/librsvg-2.32.0:2
+"
+DEPEND="${RDEPEND}"
+# libxml2:2 needed for glib-compile-resources xml-stripblanks attributes
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+ gnome-base/librsvg:2[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}