summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/peg-e/peg-e-1.2.3.ebuild')
-rw-r--r--games-board/peg-e/peg-e-1.2.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-board/peg-e/peg-e-1.2.3.ebuild b/games-board/peg-e/peg-e-1.2.3.ebuild
new file mode 100644
index 000000000000..adc3c90c22df
--- /dev/null
+++ b/games-board/peg-e/peg-e-1.2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnome2-utils qmake-utils
+
+DESCRIPTION="A peg solitaire game"
+HOMEPAGE="https://gottcode.org/peg-e/"
+SRC_URI="https://gottcode.org/peg-e/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dobin ${PN}
+ doicon -s 48 icons/hicolor/48x48/apps/${PN}.png
+ domenu icons/${PN}.desktop
+ dodoc CREDITS ChangeLog
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}