summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnuchess/files/gnuchess-6.2.2-addbook.patch10
-rw-r--r--games-board/gnuchess/gnuchess-6.2.2-r1.ebuild (renamed from games-board/gnuchess/gnuchess-6.2.2.ebuild)2
2 files changed, 12 insertions, 0 deletions
diff --git a/games-board/gnuchess/files/gnuchess-6.2.2-addbook.patch b/games-board/gnuchess/files/gnuchess-6.2.2-addbook.patch
new file mode 100644
index 000000000000..21b3dc3dd26b
--- /dev/null
+++ b/games-board/gnuchess/files/gnuchess-6.2.2-addbook.patch
@@ -0,0 +1,10 @@
+--- trunk/src/main.cc 2015/10/17 13:52:22 127
++++ trunk/src/main.cc 2015/10/18 17:28:56 128
+@@ -412,6 +412,7 @@
+ char data[9+MAXSTR+1+4]="";
+ sprintf( data, "book add %s\nquit", opt_addbook );
+ SendToEngine( data );
++ SET (flags, QUIT);
+ }
+
+ if ( opt_easy == 0 )
diff --git a/games-board/gnuchess/gnuchess-6.2.2.ebuild b/games-board/gnuchess/gnuchess-6.2.2-r1.ebuild
index 75d5001fa83a..484ec1274266 100644
--- a/games-board/gnuchess/gnuchess-6.2.2.ebuild
+++ b/games-board/gnuchess/gnuchess-6.2.2-r1.ebuild
@@ -14,6 +14,8 @@ LICENSE="GPL-3"
SLOT="0"
IUSE=""
+PATCHES=( "${FILESDIR}"/${P}-addbook.patch )
+
src_configure() {
strip-flags # bug #199097
egamesconf --without-readline # bug 491088