summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dolphin/dolphin-9999.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index c37e6af106c0..28cc6679d931 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -113,16 +113,17 @@ src_prepare() {
# This is a stripped-down mGBA for integrated GBA support
mGBA
)
- local s
- for s in "${KEEP_SOURCES[@]}"; do
- mv -v "Externals/${s}" . || die
- done
- einfo "removing sources: $(echo Externals/*)"
- rm -r Externals/* || die "Failed to delete Externals dir."
- for s in "${KEEP_SOURCES[@]}"; do
- mv -v "${s}" "Externals/" || die
+ local s remove=()
+ for s in Externals/*; do
+ [[ -f ${s} ]] && continue
+ if ! has "${s#Externals/}" "${keep_sources[@]}"; then
+ remove+=( "${s}" )
+ fi
done
+ einfo "removing sources: ${remove[*]}"
+ rm -r "${remove[@]}" || die
+
# About 50% compile-time speedup
if ! use vulkan; then
sed -i -e '/Externals\/glslang/d' CMakeLists.txt || die