summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dosbox/dosbox-0.74-r1.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-0.74-r1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/games-emulation/dosbox/dosbox-0.74-r1.ebuild b/games-emulation/dosbox/dosbox-0.74-r1.ebuild
deleted file mode 100644
index 80989eae06af..000000000000
--- a/games-emulation/dosbox/dosbox-0.74-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils games
-
-DESCRIPTION="DOS emulator"
-HOMEPAGE="http://dosbox.sourceforge.net/"
-SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
-IUSE="alsa debug hardened opengl"
-
-DEPEND="alsa? ( media-libs/alsa-lib )
- debug? ( sys-libs/ncurses:0 )
- opengl? ( virtual/glu virtual/opengl )
- media-libs/libpng:0
- media-libs/libsdl[joystick,video,X]
- media-libs/sdl-net
- media-libs/sdl-sound"
-RDEPEND=${DEPEND}
-
-PATCHES=(
- "${FILESDIR}"/${P}-clang.patch
- "${FILESDIR}"/${P}-gcc46.patch
- "${FILESDIR}"/${P}-wine-drive-z.patch
- "${FILESDIR}"/${P}-wine-filenames.patch
-)
-
-src_prepare() {
- epatch -p1 "${PATCHES[@]}"
-}
-
-src_configure() {
- egamesconf \
- $(use_enable alsa alsa-midi) \
- $(use_enable !hardened dynamic-core) \
- $(use_enable !hardened dynamic-x86) \
- $(use_enable debug) \
- $(use_enable opengl)
-}
-
-src_install() {
- default
- make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
- doicon src/dosbox.ico
- prepgamesdirs
-}