summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gnuboy/gnuboy-1.0.3-r2.ebuild')
-rw-r--r--games-emulation/gnuboy/gnuboy-1.0.3-r2.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/games-emulation/gnuboy/gnuboy-1.0.3-r2.ebuild b/games-emulation/gnuboy/gnuboy-1.0.3-r2.ebuild
index 177799b9c235..f48d05c93050 100644
--- a/games-emulation/gnuboy/gnuboy-1.0.3-r2.ebuild
+++ b/games-emulation/gnuboy/gnuboy-1.0.3-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit autotools
DESCRIPTION="Gameboy emulator with multiple renderers"
@@ -12,22 +13,24 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="X sdl"
+REQUIRED_USE="!X? ( sdl )"
RDEPEND="
sdl? ( media-libs/libsdl )
- !X? ( media-libs/libsdl )
X? ( x11-libs/libXext )
"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
"
+PATCHES=(
+ "${FILESDIR}"/${P}-exec-stack.patch
+ "${FILESDIR}"/${P}-linux-headers.patch
+ "${FILESDIR}"/${P}-include.patch
+)
+
src_prepare() {
default
- eapply \
- "${FILESDIR}"/${P}-exec-stack.patch \
- "${FILESDIR}"/${P}-linux-headers.patch \
- "${FILESDIR}"/${P}-include.patch
mv configure.in configure.ac || die
eautoreconf
@@ -36,10 +39,6 @@ src_prepare() {
src_configure() {
local myconf
- if ! use X ; then
- myconf="--with-sdl"
- fi
-
econf \
$(use_with X x) \
$(use_with sdl) \
@@ -50,11 +49,11 @@ src_configure() {
}
src_install() {
- for f in sdlgnuboy xgnuboy
- do
+ for f in sdlgnuboy xgnuboy; do
if [[ -f ${f} ]] ; then
dobin ${f}
fi
done
+
dodoc README docs/{CHANGES,CONFIG,CREDITS,FAQ,HACKING,WHATSNEW}
}