summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/nestopia/nestopia-1.47.ebuild')
-rw-r--r--games-emulation/nestopia/nestopia-1.47.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-emulation/nestopia/nestopia-1.47.ebuild b/games-emulation/nestopia/nestopia-1.47.ebuild
new file mode 100644
index 000000000000..941373c3ff51
--- /dev/null
+++ b/games-emulation/nestopia/nestopia-1.47.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gnome2-utils toolchain-funcs
+
+MY_P=${P/ue/}
+DESCRIPTION="A portable Nintendo Entertainment System emulator written in C++"
+HOMEPAGE="http://0ldsk00l.ca/nestopia/"
+SRC_URI="mirror://sourceforge/nestopiaue/${PV%.*}/${MY_P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ app-arch/libarchive:=
+ media-libs/libao
+ media-libs/libsdl2[sound,joystick,video]
+ sys-libs/zlib
+ virtual/opengl
+ virtual/glu
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS changelog.txt README.md README.unix )
+HTML_DOCS=( readme.html )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.47-fix-buildsystem.patch
+ "${FILESDIR}"/${PN}-1.47-fix-c++14.patch
+)
+
+src_configure() {
+ tc-export CXX
+ use doc && HTML_DOCS+=( doc/. )
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}