summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mednafen/Manifest1
-rw-r--r--games-emulation/mednafen/files/mednafen-0.9.38.7-cflags.patch28
-rw-r--r--games-emulation/mednafen/files/mednafen-0.9.38.7-localedir.patch278
-rw-r--r--games-emulation/mednafen/files/mednafen-0.9.38.7-zlib.patch27
-rw-r--r--games-emulation/mednafen/mednafen-0.9.38.7.ebuild68
5 files changed, 402 insertions, 0 deletions
diff --git a/games-emulation/mednafen/Manifest b/games-emulation/mednafen/Manifest
index 95cfdb7978e3..dd9924b71846 100644
--- a/games-emulation/mednafen/Manifest
+++ b/games-emulation/mednafen/Manifest
@@ -1 +1,2 @@
DIST mednafen-0.9.38.4.tar.bz2 3820560 SHA256 3298e2d5c03efbe638c2a98bf74435e306768461c65d2bb9b9a95e99dc463105 SHA512 3eb19a10e97cd285387fcf86eae09f550d248ab9c070750b1c0af0f334cce47ea375227df72cf7cdbc2193b311bab5e09108388a15634f694ef398b1a77ac3df WHIRLPOOL 17ae061668052fa33ce08b56d1aac75935bb91d02961d3dad042c07537ef15aa4374730652508941408764e7deb7cfe0969f80f32e6d642d20a32ac053bba491
+DIST mednafen-0.9.38.7.tar.bz2 3882418 SHA256 1bb3beef883a325c35d1a1ce14959c307a4c321f2ea29d4ddb216c6dd03aded8 SHA512 759c83928ef7a9e856dc7f546542ab1e7cbe944d0184a7693ce3b1466220233eb40c2b215100920920754eb5a93587bd8e2d8150e00ec9c93da1d518107e0d76 WHIRLPOOL 0cb94abdaa697558f3575c8e4d6e0a816888ace2b860797a8a947ddca3ae66e517dd044f9ce266e7a19ac6e16a56f91bc93db2bbc7a9817e5afcc75a93cb2f42
diff --git a/games-emulation/mednafen/files/mednafen-0.9.38.7-cflags.patch b/games-emulation/mednafen/files/mednafen-0.9.38.7-cflags.patch
new file mode 100644
index 000000000000..c43af818b6b8
--- /dev/null
+++ b/games-emulation/mednafen/files/mednafen-0.9.38.7-cflags.patch
@@ -0,0 +1,28 @@
+--- configure.ac.orig
++++ configure.ac
+@@ -80,25 +80,6 @@
+ AC_CHECK_LIB([z], [zlibVersion],[], AC_MSG_ERROR([*** zlib not found!]))
+ LIBS="$LIBS -lz"
+
+-OPTIMIZER_FLAGS=""
+-
+-dnl -ffast-math removed January 12, 2013. Don't re-add it, nor any of its sub-options(ESPECIALLY not -funsafe-math-optimizations),
+-dnl it messes up certain code(NES resampler, for example) under certain conditions and alignments of the great celestial squid.
+-dnl
+-dnl In fact, let's explicitly disable it here with -fno-fast-math.
+-dnl
+-dnl -fomit-frame-pointer is required for some x86 inline assembly to compile.
+-dnl
+-dnl November 28, 2014: Use -fwrapv unconditionally instead of -fno-strict-overflow, -fno-strict-overflow is buggy
+-dnl and does not work as documented/implied.
+-dnl
+-AX_CFLAGS_GCC_OPTION([-fno-fast-math], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([-fno-unsafe-math-optimizations], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([-fno-aggressive-loop-optimizations], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([-fomit-frame-pointer], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([-fwrapv], OPTIMIZER_FLAGS)
+-
+-
+ WARNING_FLAGS=""
+ AX_CFLAGS_GCC_OPTION([-Wall], WARNING_FLAGS)
+ AX_CFLAGS_GCC_OPTION([-Wshadow], WARNING_FLAGS)
diff --git a/games-emulation/mednafen/files/mednafen-0.9.38.7-localedir.patch b/games-emulation/mednafen/files/mednafen-0.9.38.7-localedir.patch
new file mode 100644
index 000000000000..5f2b3c63f6b3
--- /dev/null
+++ b/games-emulation/mednafen/files/mednafen-0.9.38.7-localedir.patch
@@ -0,0 +1,278 @@
+--- mednafen.orig/intl/Makefile.in
++++ mednafen/intl/Makefile.in
+@@ -44,7 +44,7 @@
+ includedir = @includedir@
+ datarootdir = @datarootdir@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = /usr/share/locale
+ gettextsrcdir = $(datadir)/gettext/intl
+ aliaspath = $(localedir)
+ subdir = intl
+--- mednafen.orig/src/cdplay/Makefile.am
++++ mednafen/src/cdplay/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libcdplay.a
+--- mednafen.orig/src/demo/Makefile.am
++++ mednafen/src/demo/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libdemo.a
+--- mednafen.orig/src/desa68/Makefile.am
++++ mednafen/src/desa68/Makefile.am
+@@ -6,7 +6,7 @@
+
+ AUTOMAKE_OPTIONS = subdir-objects
+ AM_CFLAGS = @AM_CFLAGS@ -Wno-multichar
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libdesa68.a
+--- mednafen.orig/src/drivers/Makefile.am
++++ mednafen/src/drivers/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@ @SDL_CFLAGS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@ @SDL_CFLAGS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libmdfnsdl.a
+--- mednafen.orig/src/drivers_dos/Makefile.am
++++ mednafen/src/drivers_dos/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@ @SDL_CFLAGS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@ @SDL_CFLAGS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libmdfndos.a
+--- mednafen.orig/src/gb/Makefile.am
++++ mednafen/src/gb/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libgb.a
+--- mednafen.orig/src/gba/Makefile.am
++++ mednafen/src/gba/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libgba.a
+--- mednafen.orig/src/hw_cpu/Makefile.am
++++ mednafen/src/hw_cpu/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libmdfnhwcpu.a
+--- mednafen.orig/src/hw_misc/Makefile.am
++++ mednafen/src/hw_misc/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libmdfnhwmisc.a
+--- mednafen.orig/src/hw_sound/Makefile.am
++++ mednafen/src/hw_sound/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libmdfnhwsound.a
+--- mednafen.orig/src/hw_video/Makefile.am
++++ mednafen/src/hw_video/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libmdfnhwvideo.a
+--- mednafen.orig/src/lynx/Makefile.am
++++ mednafen/src/lynx/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = liblynx.a
+--- mednafen.orig/src/Makefile.am
++++ mednafen/src/Makefile.am
+@@ -1,6 +1,6 @@
+ SUBDIRS = trio
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ bin_PROGRAMS = mednafen
+--- mednafen.orig/src/md/Makefile.am
++++ mednafen/src/md/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libmd.a
+--- mednafen.orig/src/nes/Makefile.am
++++ mednafen/src/nes/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libnes.a
+--- mednafen.orig/src/ngp/Makefile.am
++++ mednafen/src/ngp/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@ -fno-strict-aliasing
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@ -fno-strict-aliasing
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libngp.a
+--- mednafen.orig/src/pce/Makefile.am
++++ mednafen/src/pce/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libpce.a
+--- mednafen.orig/src/pce_fast/Makefile.am
++++ mednafen/src/pce_fast/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libpce_fast.a
+--- mednafen.orig/src/pcfx/Makefile.am
++++ mednafen/src/pcfx/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libpcfx.a
+--- mednafen.orig/src/psx/Makefile.am
++++ mednafen/src/psx/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@ @MMX_CFLAGS@ @SSE_CFLAGS@ @SSE2_CFLAGS@ -funroll-loops
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@ @MMX_CFLAGS@ @SSE_CFLAGS@ @SSE2_CFLAGS@ -funroll-loops
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libpsx.a
+--- mednafen.orig/src/quicklz/Makefile.am
++++ mednafen/src/quicklz/Makefile.am
+@@ -1,6 +1,6 @@
+ AM_CFLAGS = @AM_CFLAGS@ -fno-strict-aliasing -Wno-shadow -Wno-unused-but-set-variable
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@ -fno-strict-aliasing
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@ -fno-strict-aliasing
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libmdfnquicklz.a
+--- mednafen.orig/src/sexyal/Makefile.am
++++ mednafen/src/sexyal/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@ @SDL_CFLAGS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@ @SDL_CFLAGS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libsexyal.a
+--- mednafen.orig/src/sms/Makefile.am
++++ mednafen/src/sms/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libsms.a
+--- mednafen.orig/src/snes/Makefile.am
++++ mednafen/src/snes/Makefile.am
+@@ -1,7 +1,7 @@
+ AM_CFLAGS = @AM_CFLAGS@ @SNES_EXTRA_FLAGS@
+ AM_CXXFLAGS = @AM_CXXFLAGS@ @SNES_EXTRA_FLAGS@ @SNES_EXTRA_CXXFLAGS@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@ -DNOMINMAX
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@ -DNOMINMAX
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl -I$(srcdir)/src/lib
+
+ noinst_LIBRARIES = libsnes.a
+--- mednafen.orig/src/snes_faust/Makefile.am
++++ mednafen/src/snes_faust/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@ @MMX_CFLAGS@ @SSE_CFLAGS@ @SSE2_CFLAGS@ -funroll-loops
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@ @MMX_CFLAGS@ @SSE_CFLAGS@ @SSE2_CFLAGS@ -funroll-loops
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libsnes_faust.a
+--- mednafen.orig/src/sound/Makefile.am
++++ mednafen/src/sound/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libmdfnsound.a
+--- mednafen.orig/src/trio/Makefile.am
++++ mednafen/src/trio/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@ @TRIO_CFLAGS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@ @TRIO_CFLAGS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libtrio.a
+--- mednafen.orig/src/vb/Makefile.am
++++ mednafen/src/vb/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@ -fno-strict-aliasing
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@ -fno-strict-aliasing
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libvb.a
+--- mednafen.orig/src/wswan/Makefile.am
++++ mednafen/src/wswan/Makefile.am
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS = subdir-objects
+-DEFS = -DLOCALEDIR=\"$(datadir)/locale\" @DEFS@
++DEFS = -DLOCALEDIR=\"/usr/share/locale\" @DEFS@
+ DEFAULT_INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(top_srcdir)/intl
+
+ noinst_LIBRARIES = libwswan.a
diff --git a/games-emulation/mednafen/files/mednafen-0.9.38.7-zlib.patch b/games-emulation/mednafen/files/mednafen-0.9.38.7-zlib.patch
new file mode 100644
index 000000000000..510fb1c4a7a5
--- /dev/null
+++ b/games-emulation/mednafen/files/mednafen-0.9.38.7-zlib.patch
@@ -0,0 +1,27 @@
+--- mednafen.orig/include/mednafen/compress/Makefile.am.inc
++++ mednafen/include/mednafen/compress/Makefile.am.inc
+@@ -1 +1 @@
+-mednafen_SOURCES += compress/minilzo.c compress/ioapi.c compress/unzip.c compress/GZFileStream.cpp compress/ZLInflateFilter.cpp
++mednafen_SOURCES += compress/minilzo.c compress/ioapi.c compress/GZFileStream.cpp compress/ZLInflateFilter.cpp
+--- mednafen.orig/include/mednafen/file.cpp
++++ mednafen/include/mednafen/file.cpp
+@@ -29,7 +29,7 @@
+ #include <errno.h>
+ #include <trio/trio.h>
+
+-#include "compress/unzip.h"
++#include <minizip/unzip.h>
+
+ #include "file.h"
+ #include "general.h"
+--- mednafen.orig/include/mednafen/Makefile.am
++++ mednafen/include/mednafen/Makefile.am
+@@ -6,7 +6,7 @@
+ bin_PROGRAMS = mednafen
+
+ mednafen_SOURCES = debug.cpp error.cpp mempatcher.cpp settings.cpp endian.cpp mednafen.cpp git.cpp file.cpp general.cpp memory.cpp netplay.cpp state.cpp state_rewind.cpp movie.cpp player.cpp PSFLoader.cpp SNSFLoader.cpp SPCReader.cpp tests.cpp qtrecord.cpp Stream.cpp MemoryStream.cpp FileStream.cpp IPSPatcher.cpp
+-mednafen_LDADD = trio/libtrio.a
++mednafen_LDADD = trio/libtrio.a -lminizip
+ mednafen_DEPENDENCIES = trio/libtrio.a
+
+ if HAVE_SDL
diff --git a/games-emulation/mednafen/mednafen-0.9.38.7.ebuild b/games-emulation/mednafen/mednafen-0.9.38.7.ebuild
new file mode 100644
index 000000000000..025d9ca6a0d4
--- /dev/null
+++ b/games-emulation/mednafen/mednafen-0.9.38.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic pax-utils games
+
+DESCRIPTION="An advanced NES, GB/GBC/GBA, TurboGrafx 16/CD, NGPC and Lynx emulator"
+HOMEPAGE="http://mednafen.fobby.net/"
+SRC_URI="http://mednafen.fobby.net/releases/files/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa altivec cjk debugger jack nls pax_kernel"
+
+RDEPEND="virtual/opengl
+ media-libs/libsndfile
+ dev-libs/libcdio
+ media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/sdl-net
+ sys-libs/zlib[minizip]
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}
+
+pkg_pretend() {
+ if has ccache ${FEATURES} ; then
+ ewarn
+ ewarn "If you experience build failure, try turning off ccache in FEATURES."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-localedir.patch \
+ "${FILESDIR}"/${P}-zlib.patch \
+ "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ # very sensitive code (bug #539992)
+ strip-flags
+ append-flags -fomit-frame-pointer -fwrapv
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable altivec) \
+ $(use_enable cjk cjk-fonts) \
+ $(use_enable debugger) \
+ $(use_enable jack) \
+ $(use_enable nls)
+}
+
+src_install() {
+ DOCS="Documentation/cheats.txt ChangeLog TODO" \
+ default
+ if use pax_kernel; then
+ pax-mark m "${D}${GAMES_BINDIR}"/mednafen || die
+ fi
+ prepgamesdirs
+}