summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/libretro-info/Manifest1
-rw-r--r--games-emulation/libretro-info/libretro-info-0.0.1_pre20180723.ebuild30
-rw-r--r--games-emulation/libretro-info/libretro-info-9999.ebuild30
-rw-r--r--games-emulation/libretro-info/metadata.xml12
4 files changed, 73 insertions, 0 deletions
diff --git a/games-emulation/libretro-info/Manifest b/games-emulation/libretro-info/Manifest
new file mode 100644
index 000000000000..9e3149ca4c82
--- /dev/null
+++ b/games-emulation/libretro-info/Manifest
@@ -0,0 +1 @@
+DIST libretro-info-0.0.1_pre20180723.tar.gz 94991 BLAKE2B a5779b06d61a05a186b574c4f821da4211a03f8df89c5baa099ad805117d0f34c1349c9a83abce67d25c7c013961815d13961e3f52078107414175693950a10c SHA512 b4a1c6550d2b99ca637c824cdad7127e5eac245c12bc2f89202c42ca3da103f87205c6e4c3c6eddc572167ba302bfef91c4223939afd8d5a9012f43cc989176f
diff --git a/games-emulation/libretro-info/libretro-info-0.0.1_pre20180723.ebuild b/games-emulation/libretro-info/libretro-info-0.0.1_pre20180723.ebuild
new file mode 100644
index 000000000000..03ae3ee399fb
--- /dev/null
+++ b/games-emulation/libretro-info/libretro-info-0.0.1_pre20180723.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Libretro info files required for libretro cores"
+HOMEPAGE="https://github.com/libretro/libretro-super"
+
+if [[ ${PV} == *9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/libretro/libretro-super.git"
+ inherit git-r3
+else
+ COMMIT="dfa0eaaa804552712baaff5553df3eea989fc5d5"
+ SRC_URI="https://github.com/libretro/libretro-super/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/libretro-super-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto "/usr/share/libretro/info"
+ doins dist/info/*.info
+}
diff --git a/games-emulation/libretro-info/libretro-info-9999.ebuild b/games-emulation/libretro-info/libretro-info-9999.ebuild
new file mode 100644
index 000000000000..03ae3ee399fb
--- /dev/null
+++ b/games-emulation/libretro-info/libretro-info-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Libretro info files required for libretro cores"
+HOMEPAGE="https://github.com/libretro/libretro-super"
+
+if [[ ${PV} == *9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/libretro/libretro-super.git"
+ inherit git-r3
+else
+ COMMIT="dfa0eaaa804552712baaff5553df3eea989fc5d5"
+ SRC_URI="https://github.com/libretro/libretro-super/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/libretro-super-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto "/usr/share/libretro/info"
+ doins dist/info/*.info
+}
diff --git a/games-emulation/libretro-info/metadata.xml b/games-emulation/libretro-info/metadata.xml
new file mode 100644
index 000000000000..7754440a0cc5
--- /dev/null
+++ b/games-emulation/libretro-info/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <longdescription>Libretro info files required for libretro cores</longdescription>
+ <upstream>
+ <remote-id type="github">libretro/libretro-super</remote-id>
+ </upstream>
+</pkgmetadata>