summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/vbam/Manifest1
-rw-r--r--games-emulation/vbam/files/vbam-2.0.1-changelog-update.patch98
-rw-r--r--games-emulation/vbam/files/vbam-2.0.1-read-version-from-changelog.patch76
-rw-r--r--games-emulation/vbam/vbam-2.0.1.ebuild105
4 files changed, 280 insertions, 0 deletions
diff --git a/games-emulation/vbam/Manifest b/games-emulation/vbam/Manifest
index 63bffba32381..1c14b64fd996 100644
--- a/games-emulation/vbam/Manifest
+++ b/games-emulation/vbam/Manifest
@@ -1 +1,2 @@
DIST vbam-2.0.0_beta2_p20161211.tar.gz 3075570 BLAKE2B 69b1272f5e048fe96a7a6798a3f934395a607439ba3ede992f8d49557a4ea8ea64ed512f11440200548eb039d3b1f4b4129603e5a897f3e04fac48d4d39906f1 SHA512 1130a976e6e9e504af96ec9218cd35af10ded7ab184ec468ba40b641faaefac47cbb225c6221278031015081632be04ae125a2653379d2b08877f162c6cb4a40
+DIST vbam-2.0.1.tar.gz 2926632 BLAKE2B 3a2d44b76a9b03eadcce530a955e6b2ebde48340d8462e1ad339f4a02b1d19b8f8fbd0d9671f12eb5ed14ee600dba6e6bb6d167f9ca1cfb192ffb734ace72752 SHA512 d6cdc1ab1fbc20f81483fb4dc316d65dc9d7c0f378d5c85c1c5ca1251fbd1e7aad9f2f6bd5ecc2ff0b832e42c010cc82b9b1ec68bbb0a49aa8e00683fb5264bb
diff --git a/games-emulation/vbam/files/vbam-2.0.1-changelog-update.patch b/games-emulation/vbam/files/vbam-2.0.1-changelog-update.patch
new file mode 100644
index 000000000000..6d4f87f2d772
--- /dev/null
+++ b/games-emulation/vbam/files/vbam-2.0.1-changelog-update.patch
@@ -0,0 +1,98 @@
+From 30b6ecf1a5c0eac73aaf3dabd98e41c908daa94a Mon Sep 17 00:00:00 2001
+From: Zach Bacon <zachbacon@budgiemedia.rocks>
+Date: Thu, 12 Oct 2017 00:49:05 +0000
+Subject: [PATCH] Add a changelog
+
+Gonna try and keep this up to date as often as possible.
+---
+ CHANGELOG.md | 81 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 81 insertions(+)
+ create mode 100644 CHANGELOG.md
+
+diff --git a/CHANGELOG.md b/CHANGELOG.md
+new file mode 100644
+index 00000000..c24ac560
+--- /dev/null
++++ b/CHANGELOG.md
+@@ -0,0 +1,81 @@
++# Changelog
++All notable changes to this project will be documented in this file.
++
++The format is based on [Keep a Changelog](http://keepachangelog.com/en/1.0.0/)
++and this project adheres to [Semantic Versioning](http://semver.org/spec/v2.0.0.html).
++
++## [Unreleased]
++
++## [2.0.1] - 10/11/2017
++### Added
++- initial installer script
++- gitter.im badge in readme
++- 32bit cross compiling support on 64bit linux
++- added support for GNUInstallDirs to cmake
++- Include new translations from transifex
++- Added WxWidgets ABI compiler check
++- Add linux Joystick reference to issue template
++- Add #ubckyde <cmath> fir std::cell()
++-
++
++### Changed
++- Fix 2xSaImmx.asm linking issue
++- cmake: default to ENABLE_ASM_CORE=OFF
++- libretro merging from upstream libretro fork.
++- better fix for clipped video in GL Fullscreen.
++- Fix flibc crash: add log message on fopen failure
++- fix gameboy header-detection in libretro interface
++- hotfix for potential buffer-overflow
++- delete memory in common/array.h on destruction
++- SDL: improve error msg for unwritable config
++- SDL: fix deflt bat saving, improve dir checking
++- fix portability issue with strerror_r()
++- Windows doesn't have sterror_r
++- wx/wxvbam: fix GetAbsolutePath
++- fix a memory leak due to wrong syntax
++- regenerate translation files
++- fix errors reported by SUSE's post build linter
++- SUSE Lint: fix a few classes of warnings
++- let cmake escape -D preproc. definitions
++- fix memory viewer xrc on wx 3.1+
++- Improving README
++- SoundSDL: lock conditional code cleanup
++- remove the default F11 keybinding for save state
++- hopefully fix resize artifacts on game panel
++- soundSDL: write silence when paused
++- cleanup SoundSDL #139 #130 #97 #67 #65 #46 #47
++- document how to provice symbolic backtraces
++- "no throttle" fixes/cleanup
++- only use -mtune=generic on x86/amd64
++- installdeps: use -j$(nproc) not -j8 in info
++- use -fabi-version=2 for GCC turn off LTO
++- installdeps: minor refactoring/cleanup
++- improve Wx GCC ABI check
++- minor improvements for Wx Compile tests
++- fix wx ABI check for Win32/MinGW
++- installdeps: fedora fixes, including m32
++- cmake: wx and cross compiling fixes
++- restore wx 2.7 compat, improve string processing
++- rename CMakeScripts/ to cmake/
++- work around gcc lto wrappers bug with gcc 7.x
++- update README.md
++- remove doctoc title from README.md TOC
++- improve win32 dependencies git submodule handling
++- use num cpu cores to parallelize LTO link with gcc
++- fix huge app icon in Win volume settings
++- fix deadlock in SoundSDL:deinit()
++- added executable extension for sdl binary
++- default LTO to off on 64bit MinGW
++- minor code cleanup
++- deps: dont check result of apt-get update
++- read version and subversion info from Git
++- fix error and version info in shallow git clones
++- refactor/cleanup GitTagVersion.cmake
++
++### Removed
++- Cairo Renderer: it never performed well to begin with
++
++
++
++[2.0.1]: https://github.com/olivierlacan/keep-a-changelog/compare/throttle...v2.0.1
++
diff --git a/games-emulation/vbam/files/vbam-2.0.1-read-version-from-changelog.patch b/games-emulation/vbam/files/vbam-2.0.1-read-version-from-changelog.patch
new file mode 100644
index 000000000000..5dce58395343
--- /dev/null
+++ b/games-emulation/vbam/files/vbam-2.0.1-read-version-from-changelog.patch
@@ -0,0 +1,76 @@
+From 46486381f0c18110002ec62108969be957b419be Mon Sep 17 00:00:00 2001
+From: Rafael Kitover <rkitover@gmail.com>
+Date: Wed, 11 Oct 2017 19:17:25 -0700
+Subject: [PATCH] read version info from CHANGELOG.md if no git
+
+If git tags are not available, set the version and revision by finding
+the first version tag in `CHANGELOG.md` of the form
+
+```
+```
+
+Where N.N.N is the number version (number of components can vary) and
+the revision (as speicified by -REV) is optional.
+
+TODO: support named revision without a version number of the form
+`[REV]`.
+---
+ CMakeLists.txt | 9 +++------
+ cmake/ChangeLogVersion.cmake | 25 +++++++++++++++++++++++++
+ 2 files changed, 28 insertions(+), 6 deletions(-)
+ create mode 100644 cmake/ChangeLogVersion.cmake
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index bd09527d..4ad859b2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -112,15 +112,12 @@ if(GIT_FOUND AND EXISTS "${CMAKE_SOURCE_DIR}/.git")
+ # of files that depend on version.h
+ include(GetGitRevisionDescription)
+ get_git_head_revision(REFSPEC COMMITHASH)
+-else()
+- message(WARNING "Git not found, cannot set version info")
+ endif()
+
+-# no git or no tags
++# no git or no tags, use ChangeLog
+ if(NOT VERSION)
+- set(VERSION 2.0.0)
+- set(REVISION "unknown")
+- set(VERSION_RELEASE 0)
++ include(ChangeLogVersion)
++ changelog_version(VERSION REVISION VERSION_RELEASE)
+ endif()
+
+ # generate version.h
+diff --git a/cmake/ChangeLogVersion.cmake b/cmake/ChangeLogVersion.cmake
+new file mode 100644
+index 00000000..101d23bd
+--- /dev/null
++++ b/cmake/ChangeLogVersion.cmake
+@@ -0,0 +1,25 @@
++function(changelog_version version revision version_release)
++ set(${version} "" CACHE STRING "Latest ChangeLog Version" FORCE)
++ set(${revision} "" CACHE STRING "Latest ChangeLog Revision" FORCE)
++ set(${version_release} 0 CACHE STRING "Is this a versioned release without revision" FORCE)
++
++ file(READ CHANGELOG.md changelog_file)
++
++ if(NOT changelog_file)
++ return()
++ endif()
++
++ string(REGEX MATCH "\n## +\\[([0-9.]+)(-([^] ]+))?\\] +- +[0-9][0-9]?/" match_out "${changelog_file}")
++
++ set(changelog_version "${CMAKE_MATCH_1}")
++
++ set(is_version_release 0)
++ set(changelog_revision "${CMAKE_MATCH_3}")
++ if(NOT changelog_revision)
++ set(is_version_release 1)
++ endif()
++
++ set(${version} "${changelog_version}" CACHE STRING "Latest ChangeLog Version" FORCE)
++ set(${revision} "${changelog_revision}" CACHE STRING "Latest ChangeLog Revision" FORCE)
++ set(${version_release} "${is_version_release}" CACHE STRING "Is this a versioned release without revision" FORCE)
++endfunction()
diff --git a/games-emulation/vbam/vbam-2.0.1.ebuild b/games-emulation/vbam/vbam-2.0.1.ebuild
new file mode 100644
index 000000000000..c564e02df5d5
--- /dev/null
+++ b/games-emulation/vbam/vbam-2.0.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0"
+inherit cmake-utils wxwidgets gnome2-utils eutils xdg-utils
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/visualboyadvance-m/visualboyadvance-m.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/visualboyadvance-m/visualboyadvance-m/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/visualboyadvance-m-${PV}"
+fi
+
+DESCRIPTION="Game Boy, GBC, and GBA emulator forked from VisualBoyAdvance"
+HOMEPAGE="https://github.com/visualboyadvance-m/visualboyadvance-m"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ffmpeg link lirc nls openal +sdl wxwidgets"
+REQUIRED_USE="openal? ( wxwidgets ) || ( sdl wxwidgets )"
+
+RDEPEND=">=media-libs/libpng-1.4:0=
+ media-libs/libsdl2[joystick]
+ link? ( >=media-libs/libsfml-2.0:= )
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ ffmpeg? ( virtual/ffmpeg[-libav] )
+ lirc? ( app-misc/lirc )
+ nls? ( virtual/libintl )
+ wxwidgets? (
+ openal? ( media-libs/openal )
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+ )"
+DEPEND="${RDEPEND}
+ wxwidgets? ( virtual/imagemagick-tools )
+ x86? ( || ( dev-lang/nasm dev-lang/yasm ) )
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-changelog-update.patch"
+ "${FILESDIR}/${P}-read-version-from-changelog.patch"
+)
+
+src_prepare() {
+ default
+
+ # fix desktop file QA warnings
+ edos2unix src/wx/wxvbam.desktop
+}
+
+src_configure() {
+ use wxwidgets && setup-wxwidgets
+ local mycmakeargs=(
+ -DENABLE_FFMPEG=$(usex ffmpeg)
+ -DENABLE_LINK=$(usex link)
+ -DENABLE_LIRC=$(usex lirc)
+ -DENABLE_NLS=$(usex nls)
+ -DENABLE_OPENAL=$(usex openal)
+ -DENABLE_SDL=$(usex sdl)
+ -DENABLE_WX=$(usex wxwidgets)
+ -DENABLE_ASM_CORE=$(usex x86)
+ -DENABLE_ASM_SCALERS=$(usex x86)
+ -DCMAKE_SKIP_RPATH=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use sdl ; then
+ dodoc doc/ReadMe.SDL.txt
+ doman src/debian/vbam.6
+ fi
+ use wxwidgets && doman src/debian/visualboyadvance-m.6
+}
+
+pkg_preinst() {
+ if use wxwidgets ; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use wxwidgets ; then
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ fi
+}
+
+pkg_postrm() {
+ if use wxwidgets ; then
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ fi
+}