summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/love/love-0.7.2-r1.ebuild')
-rw-r--r--games-engines/love/love-0.7.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-engines/love/love-0.7.2-r1.ebuild b/games-engines/love/love-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..007840f5b88c
--- /dev/null
+++ b/games-engines/love/love-0.7.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A framework for 2D games in Lua"
+HOMEPAGE="http://love2d.org/"
+SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0.7"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-games/physfs
+ dev-lang/lua[deprecated]
+ media-libs/devil[mng,png,tiff]
+ media-libs/freetype
+ media-libs/libmodplug
+ media-libs/libsdl[joystick,opengl]
+ media-libs/libvorbis
+ media-libs/openal
+ media-sound/mpg123
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ media-libs/libmng
+ media-libs/tiff"
+
+S=${WORKDIR}/${PN}-HEAD
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.0-freetype2.patch
+}
+
+src_install() {
+ DOCS="readme.txt changes.txt" \
+ default
+ if [[ "${SLOT}" != "0" ]]; then
+ mv "${ED}${GAMES_BINDIR}"/${PN} \
+ "${ED}${GAMES_BINDIR}"/${PN}-${SLOT} || die
+ fi
+}